Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Keyboard configuration database for X Window" |
| 2 | |
| 3 | DESCRIPTION = "The non-arch keyboard configuration database for X \ |
| 4 | Window. The goal is to provide the consistent, well-structured, \ |
| 5 | frequently released open source of X keyboard configuration data for X \ |
| 6 | Window System implementations. The project is targeted to XKB-based \ |
| 7 | systems." |
| 8 | |
| 9 | HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig" |
| 10 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config" |
| 11 | |
| 12 | LICENSE = "MIT & MIT-style" |
| 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9" |
| 14 | |
| 15 | SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.bz2" |
| 16 | SRC_URI[md5sum] = "4af1deeb7c5f4cad62e65957d98d6758" |
| 17 | SRC_URI[sha256sum] = "0e443cf7ca2f0b40846472c029647a05933fc705d611e1478c4db8a48a6f38bf" |
| 18 | |
| 19 | SECTION = "x11/libs" |
| 20 | DEPENDS = "intltool-native virtual/gettext util-macros libxslt-native" |
| 21 | |
| 22 | EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps" |
| 23 | |
| 24 | FILES_${PN} += "${datadir}/X11/xkb" |
| 25 | |
| 26 | inherit autotools pkgconfig gettext |
| 27 | |
| 28 | do_install_append () { |
| 29 | install -d ${D}${datadir}/X11/xkb/compiled |
| 30 | cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg |
| 31 | } |