blob: e967958c021a8670645b8b57d16400d34169f5b3 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Backport of functools.lru_cache from Python 3.3"
2HOMEPAGE = "https://github.com/jaraco/backports.functools_lru_cache"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a33f38bbf47d48c70fe0d40e5f77498e"
6
7PYPI_PACKAGE = "backports.functools_lru_cache"
8
9SRC_URI[md5sum] = "103000b21a8e683647e2ce41929f2a9d"
10SRC_URI[sha256sum] = "8fde5f188da2d593bd5bc0be98d9abc46c95bb8a9dde93429570192ee6cc2d4a"
11
12DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
13
Andrew Geisslerd221e032020-07-10 16:13:21 -050014inherit pypi setuptools3 ptest
15
16SRC_URI += " \
17 file://run-ptest \
18"
19
20RDEPENDS_${PN}-ptest += " \
21 ${PYTHON_PN}-pytest \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}
Andrew Geissler82c905d2020-04-13 13:39:40 -050028
29RDEPENDS_${PN} += "\
30 ${PYTHON_PN}-pickle \
31 ${PYTHON_PN}-threading \
32 "