Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Python binding to the Networking and Cryptography (NaCl) library" |
| 2 | DESCRIPTION = "Python binding to the Networking and Cryptography (NaCl) library" |
| 3 | HOMEPAGE = "https://github.com/pyca/pynacl" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8cc789b082b3d97e1ccc5261f8594d3f" |
| 6 | |
| 7 | SRC_URI[md5sum] = "8c6c57893327a694c72510fb620e4744" |
| 8 | SRC_URI[sha256sum] = "54e9a2c849c742006516ad56a88f5c74bf2ce92c9f67435187c3c5953b346505" |
| 9 | |
| 10 | PYPI_PACKAGE = "PyNaCl" |
| 11 | |
| 12 | inherit pypi setuptools3 |
| 13 | |
| 14 | DEPENDS += "\ |
| 15 | ${PYTHON_PN}-wheel-native \ |
| 16 | ${PYTHON_PN}-cffi-native \ |
| 17 | libsodium \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS_${PN} = "\ |
| 21 | ${PYTHON_PN}-six \ |
| 22 | ${PYTHON_PN}-cffi \ |
| 23 | libsodium \ |
| 24 | " |
| 25 | |
| 26 | do_compile_prepend() { |
| 27 | export SODIUM_INSTALL=system |
| 28 | } |
| 29 | |
| 30 | do_install_prepend() { |
| 31 | export SODIUM_INSTALL=system |
| 32 | } |