Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Hierarchical, reference counted memory pool system with destructors" |
| 2 | HOMEPAGE = "http://ldb.samba.org" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "LGPL-3.0+ & LGPL-2.1+ & GPL-3.0+" |
| 5 | |
| 6 | DEPENDS += "libtdb libtalloc libtevent popt" |
| 7 | RDEPENDS_pyldb += "python" |
| 8 | |
| 9 | SRC_URI = "http://samba.org/ftp/ldb/ldb-${PV}.tar.gz \ |
| 10 | file://do-not-import-target-module-while-cross-compile.patch \ |
| 11 | file://options-1.3.1.patch \ |
| 12 | " |
| 13 | |
| 14 | PACKAGECONFIG ??= "\ |
| 15 | ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \ |
| 16 | ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \ |
| 17 | " |
| 18 | PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl" |
| 19 | PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr" |
| 20 | PACKAGECONFIG[ldap] = ",,openldap" |
| 21 | PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio" |
| 22 | PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd" |
| 23 | PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap" |
| 24 | PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind" |
| 25 | |
| 26 | SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'ldap', '', 'file://avoid-openldap-unless-wanted.patch', d)}" |
| 27 | |
| 28 | LIC_FILES_CHKSUM = "file://pyldb.h;endline=24;md5=dfbd238cecad76957f7f860fbe9adade \ |
| 29 | file://man/ldb.3.xml;beginline=261;endline=262;md5=137f9fd61040c1505d1aa1019663fd08 \ |
| 30 | file://tools/ldbdump.c;endline=19;md5=a7d4fc5d1f75676b49df491575a86a42" |
| 31 | |
| 32 | SRC_URI[md5sum] = "e5233f202bca27f6ce8474fb8ae65983" |
| 33 | SRC_URI[sha256sum] = "b19f2c9f55ae0f46aa5ebaea0bf1a47ec1ac135e1d78af0f6318cf50bf62cbd2" |
| 34 | |
| 35 | CROSS_METHOD="exec" |
| 36 | inherit waf-samba |
| 37 | |
| 38 | S = "${WORKDIR}/ldb-${PV}" |
| 39 | |
| 40 | EXTRA_OECONF += "--disable-rpath \ |
| 41 | --disable-rpath-install \ |
| 42 | --bundled-libraries=cmocka \ |
| 43 | --builtin-libraries=replace \ |
| 44 | --with-modulesdir=${libdir}/ldb/modules \ |
| 45 | --with-privatelibdir=${libdir}/ldb \ |
| 46 | --with-libiconv=${STAGING_DIR_HOST}${prefix}\ |
| 47 | " |
| 48 | |
| 49 | PACKAGES =+ "pyldb pyldb-dbg pyldb-dev" |
| 50 | |
| 51 | NOAUTOPACKAGEDEBUG = "1" |
| 52 | |
| 53 | FILES_${PN} += "${libdir}/ldb/*" |
| 54 | FILES_${PN}-dbg += "${bindir}/.debug/* \ |
| 55 | ${libdir}/.debug/* \ |
| 56 | ${libdir}/ldb/.debug/* \ |
| 57 | ${libdir}/ldb/modules/ldb/.debug/*" |
| 58 | |
| 59 | FILES_pyldb = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/* \ |
| 60 | ${libdir}/libpyldb-util.so.* \ |
| 61 | " |
| 62 | FILES_pyldb-dbg = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug \ |
| 63 | ${libdir}/.debug/libpyldb-util.so.*" |
| 64 | FILES_pyldb-dev = "${libdir}/libpyldb-util.so" |