Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | # NOTE: mosh-server requires a UTF-8 locale, but there's no way to add |
| 2 | # an explicit dependency for this so you need to ensure this is in your |
| 3 | # image yourself when you install mosh-server. |
| 4 | |
| 5 | SUMMARY = "Remote shell supporting roaming and high-latency connections" |
| 6 | DESCRIPTION = "Remote terminal application that allows roaming, supports \ |
| 7 | intermittent connectivity, and provides intelligent local echo and line \ |
| 8 | editing of user keystrokes. Mosh is a replacement for SSH. It's more \ |
| 9 | robust and responsive, especially over Wi-Fi, cellular, and \ |
| 10 | long-distance links." |
| 11 | HOMEPAGE = "http://mosh.mit.edu" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 12 | LICENSE = "GPL-3.0-or-later" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 14 | |
| 15 | DEPENDS = "protobuf-native protobuf ncurses zlib libio-pty-perl openssl libutempter" |
| 16 | |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 17 | SRC_URI = "http://mosh.mit.edu/mosh-${PV}.tar.gz" |
| 18 | SRC_URI[sha256sum] = "872e4b134e5df29c8933dff12350785054d2fd2839b5ae6b5587b14db1465ddd" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 19 | |
| 20 | inherit autotools pkgconfig |
| 21 | |
| 22 | PACKAGE_BEFORE_PN += "${PN}-server" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | FILES:${PN}-server = "${bindir}/mosh-server" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 24 | |
| 25 | NEEDED_PERL_MODULES = "\ |
| 26 | perl-module-socket \ |
| 27 | perl-module-getopt-long \ |
| 28 | perl-module-errno \ |
| 29 | perl-module-io-socket-inet \ |
| 30 | perl-module-posix \ |
| 31 | " |
| 32 | |
| 33 | # mosh uses SSH to authenticate and the client uses OpenSSH-specific features |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | RDEPENDS:${PN} += "openssh-ssh ${NEEDED_PERL_MODULES}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 35 | # The server seemed not to work with dropbear either |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 36 | RDEPENDS:${PN}-server += "openssh-sshd" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 37 | |
| 38 | # Fails to build with thumb-1 (qemuarm) |
| 39 | #| {standard input}: Assembler messages: |
| 40 | #| {standard input}:2100: Error: instruction not supported in Thumb16 mode -- `adds r4,r4,r4' |
| 41 | #| {standard input}:2101: Error: instruction not supported in Thumb16 mode -- `adcs r5,r5,r5' |
| 42 | #| {standard input}:2102: Error: instruction not supported in Thumb16 mode -- `adcs r6,r6,r6' |
| 43 | #| {standard input}:2103: Error: instruction not supported in Thumb16 mode -- `adcs r7,r7,r7' |
| 44 | #| {standard input}:2104: Error: selected processor does not support Thumb mode `it cs' |
| 45 | ARM_INSTRUCTION_SET = "arm" |