Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Linux tool to dump x86 CPUID information about the CPU(s)" |
| 2 | DESCRIPTION = "cpuid dumps detailed information about the CPU(s) gathered \ |
| 3 | from the CPUID instruction, and also determines the exact model of CPU(s). \ |
| 4 | It supports Intel, AMD, and VIA CPUs, as well as older Transmeta, Cyrix, \ |
| 5 | UMC, NexGen, Rise, and SiS CPUs" |
| 6 | HOMEPAGE="http://www.etallen.com/cpuid.html" |
| 7 | LICENSE = "GPL-2.0-only" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 9 | |
| 10 | SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 11 | file://0001-Makefile-update-the-hardcode-path-to-bindir-mandir.patch \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 12 | " |
| 13 | SRC_URI[sha256sum] = "b1c83045efc26076307751e0662d580277f5f9bf89cf027231a7812003c3a4e8" |
| 14 | |
| 15 | COMPATIBLE_HOST = "(i.86|x86_64).*-linux" |
| 16 | |
| 17 | inherit perlnative |
| 18 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 19 | do_install () { |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 20 | oe_runmake DESTDIR=${D} bindir=${bindir} mandir=${mandir} install |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 21 | } |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 22 | |
| 23 | RDEPENDS:${PN} = "perl" |
| 24 | |
| 25 | INSANE_SKIP:${PN} += "already-stripped" |