blob: 8ee92167d7b28588ec519f45862e164ddba5aa95 [file] [log] [blame]
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05001SUMMARY = "IPython: Productive Interactive Computing"
2HOMEPAGE = "https://ipython.org"
3AUTHOR = "The IPython Development Team <ipython-dev@python.org>"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING.rst;md5=59b20262b8663cdd094005bddf47af5f"
6
7PYPI_PACKAGE = "ipython"
8
Andrew Geisslerd688a012020-09-18 13:36:00 -05009SRC_URI[md5sum] = "f2db1158dc40d70a31b6bbef86e74789"
10SRC_URI[sha256sum] = "a331e78086001931de9424940699691ad49dfb457cea31f5471eae7b78222d5e"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050011
12RDEPENDS_${PN} = "\
13 ${PYTHON_PN}-setuptools \
14 ${PYTHON_PN}-jedi \
15 ${PYTHON_PN}-decorator \
16 ${PYTHON_PN}-pickleshare \
17 ${PYTHON_PN}-traitlets \
18 ${PYTHON_PN}-prompt-toolkit \
19 ${PYTHON_PN}-pygments \
20 ${PYTHON_PN}-backcall \
21 ${PYTHON_PN}-pydoc \
22 ${PYTHON_PN}-debugger \
23 ${PYTHON_PN}-pexpect \
24 ${PYTHON_PN}-unixadmin \
25 ${PYTHON_PN}-misc \
26 ${PYTHON_PN}-sqlite3 \
27"
28
29inherit setuptools3 pypi