Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Bindings for the scrypt key derivation function library" |
| 2 | LICENSE = "BSD-2-Clause" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=168ff75417f75a83e63c8875292d44dc" |
| 4 | HOMEPAGE="https://bitbucket.org/mhallin/py-scrypt/overview" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 5 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 6 | SRC_URI += "file://0001-py-scrypt-remove-the-hard-coded-include-paths.patch" |
| 7 | |
| 8 | SRC_URI[md5sum] = "ae8e3263aa31b040c1f9c7f1e1843a56" |
| 9 | SRC_URI[sha256sum] = "f8239b2d47fa1d40bc27efd231dc7083695d10c1c2ac51a99380360741e0362d" |
| 10 | |
| 11 | inherit pypi ptest setuptools3 |
| 12 | |
| 13 | SRC_URI += " \ |
| 14 | file://run-ptest \ |
| 15 | " |
| 16 | |
| 17 | RDEPENDS_${PN}-ptest += " \ |
| 18 | ${PYTHON_PN}-pytest \ |
| 19 | " |
| 20 | |
| 21 | do_install_ptest() { |
| 22 | install -d ${D}${PTEST_PATH}/tests |
| 23 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 24 | } |