blob: 44a6f5de032a17e5ad2885da7c984963671762a0 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Canonical source for classifiers on PyPI (pypi.org)."
2HOMEPAGE = "https://github.com/pypa/trove-classifiers"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
5
Patrick Williamsda295312023-12-05 16:48:56 -06006SRC_URI[sha256sum] = "c31a7e92f965f060a244b57d8ed5ee6f53fcb413ee17ce790e00577cb369ad99"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06007
8inherit pypi python_setuptools_build_meta ptest
9
10DEPENDS += " python3-calver-native"
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS:${PN}-ptest += " \
17 ${PYTHON_PN}-pytest \
18 ${PYTHON_PN}-unittest-automake-output \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}
25
26BBCLASSEXTEND = "native nativesdk"