blob: 363ed4d650799446b867d008414080e8a592273c [file] [log] [blame]
Andrew Geissler7f40b712020-05-15 14:09:53 -05001SUMMARY = "the Git linkable library"
2HOMEPAGE = "http://libgit2.github.com/"
3LICENSE = "GPL-2.0-with-GCC-exception & MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=5b002a195fb7ea2d8d583f07eaff3a8e"
5
6DEPENDS = "curl openssl zlib libssh2 libgcrypt libpcre2"
7
8SRC_URI = "git://github.com/libgit2/libgit2.git;branch=maint/v1.0"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05009SRCREV = "0ced29612dacb67eefe0c562a5c1d3aab21cce96"
Andrew Geissler7f40b712020-05-15 14:09:53 -050010
11S = "${WORKDIR}/git"
12
13inherit cmake
14
15EXTRA_OECMAKE = "\
16 -DBUILD_CLAR=OFF \
17 -DCMAKE_BUILD_TYPE=RelWithDebInfo \
18 -DLIB_INSTALL_DIR=${libdir} \
19 -DREGEX_BACKEND='pcre2' \
20"
21
22BBCLASSEXTEND = "native"