blob: 2d484d4b2c159c159604cbbb664a22a2a3daa0b6 [file] [log] [blame]
Andrew Geissler3eeda902023-05-19 10:14:02 -05001SUMMARY = "Canonical source for classifiers on PyPI (pypi.org)."
2HOMEPAGE = "https://github.com/pypa/trove-classifiers"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
5
Patrick Williamsb542dec2023-06-09 01:26:37 -05006SRC_URI[sha256sum] = "fd5a1546283be941f47540a135bdeae8fb261380a6a204d9c18012f2a1b0ceae"
Andrew Geissler3eeda902023-05-19 10:14:02 -05007
8inherit pypi python_setuptools_build_meta ptest
9
10DEPENDS += " python3-calver-native"
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS:${PN}-ptest += " \
17 ${PYTHON_PN}-pytest \
18 ${PYTHON_PN}-unittest-automake-output \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}
25
26BBCLASSEXTEND = "native nativesdk"