Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Tooling for devicetree validation using YAML and jsonschema" |
| 2 | HOMEPAGE = "https://github.com/devicetree-org/dt-schema" |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=457495c8fa03540db4a576bf7869e811" |
| 5 | |
| 6 | inherit pypi setuptools3 |
| 7 | |
| 8 | PYPI_PACKAGE = "dtschema" |
| 9 | |
| 10 | SRC_URI[sha256sum] = "3e56a9920944223d6f93fd51ada19dd8db554ac9182ef52c1c5c9d4966ab30aa" |
| 11 | |
| 12 | DEPENDS += "python3-setuptools-scm-native" |
| 13 | RDEPENDS:${PN} += "python3-ruamel-yaml python3-jsonschema python3-rfc3987" |
| 14 | |
| 15 | BBCLASSEXTEND = "native nativesdk" |