blob: 458958edf5b26beec80ae6133fc30fa71c65dc89 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Light-weight C++ XML Processing Library"
2DESCRIPTION = "pugixml is a C++ XML processing library, which consists of a \
3DOM-like interface with rich traversal/modification capabilities, \
4an extremely fast XML parser which constructs the DOM tree from \
5n XML file/buffer, and an XPath 1.0 implementation for complex \
6data-driven tree queries."
7HOMEPAGE = "https://pugixml.org/"
8
9LICENSE = "MIT"
Andrew Geissler20137392023-10-12 04:59:14 -060010LIC_FILES_CHKSUM = "file://readme.txt;beginline=29;endline=52;md5=ad370df61d83846cf9e4726244671201"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000011
12SRC_URI = "https://github.com/zeux/${BPN}/releases/download/v${PV}/${BP}.tar.gz"
Andrew Geissler20137392023-10-12 04:59:14 -060013SRC_URI[sha256sum] = "2f10e276870c64b1db6809050a75e11a897a8d7456c4be5c6b2e35a11168a015"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000014
15UPSTREAM_CHECK_URI = "https://github.com/zeux/${BPN}/releases"
16
17inherit cmake
18
19EXTRA_OECMAKE += "-DBUILD_PKGCONFIG=ON \
20 -DBUILD_SHARED_LIBS=ON \
21 -DCMAKE_BUILD_TYPE=Release \
22 "
23
24BBCLASSEXTEND = "native nativesdk"