Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Light-weight C++ XML Processing Library" |
| 2 | DESCRIPTION = "pugixml is a C++ XML processing library, which consists of a \ |
| 3 | DOM-like interface with rich traversal/modification capabilities, \ |
| 4 | an extremely fast XML parser which constructs the DOM tree from \ |
| 5 | n XML file/buffer, and an XPath 1.0 implementation for complex \ |
| 6 | data-driven tree queries." |
| 7 | HOMEPAGE = "https://pugixml.org/" |
| 8 | |
| 9 | LICENSE = "MIT" |
Andrew Geissler | 2013739 | 2023-10-12 04:59:14 -0600 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://readme.txt;beginline=29;endline=52;md5=ad370df61d83846cf9e4726244671201" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 11 | |
| 12 | SRC_URI = "https://github.com/zeux/${BPN}/releases/download/v${PV}/${BP}.tar.gz" |
Andrew Geissler | 2013739 | 2023-10-12 04:59:14 -0600 | [diff] [blame] | 13 | SRC_URI[sha256sum] = "2f10e276870c64b1db6809050a75e11a897a8d7456c4be5c6b2e35a11168a015" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 14 | |
| 15 | UPSTREAM_CHECK_URI = "https://github.com/zeux/${BPN}/releases" |
| 16 | |
| 17 | inherit cmake |
| 18 | |
| 19 | EXTRA_OECMAKE += "-DBUILD_PKGCONFIG=ON \ |
| 20 | -DBUILD_SHARED_LIBS=ON \ |
| 21 | -DCMAKE_BUILD_TYPE=Release \ |
| 22 | " |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |