Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 1 | SUMMARY = "C++11 command line parser" |
| 2 | DESCRIPTION = "A command line parser for C++11 and beyond that provides a rich feature set with a simple and intuitive interface." |
| 3 | HOMEPAGE = "https://github.com/CLIUtils/CLI11" |
| 4 | LICENSE = "BSD-3-Clause" |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=afb20fe5f67e21074b10b864d9563c11" |
| 6 | SRCREV = "291c58789c031208f08f4f261a858b5b7083e8e2" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 7 | PV .= "+git${SRCPV}" |
| 8 | |
| 9 | SRC_URI += "gitsm://github.com/CLIUtils/CLI11;branch=main;protocol=https \ |
| 10 | https://github.com/philsquared/Catch/releases/download/v2.13.7/catch.hpp \ |
| 11 | file://0001-Do-not-download-the-catch-framework-during-configure.patch" |
| 12 | |
| 13 | SRC_URI[sha256sum] = "ea379c4a3cb5799027b1eb451163dff065a3d641aaba23bf4e24ee6b536bd9bc" |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | do_configure:prepend() { |
| 17 | mkdir -p ${S}/tests/catch2 |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 18 | cp ${DL_DIR}/catch.hpp ${S}/tests/catch2/catch.hpp |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 19 | } |
| 20 | |
| 21 | inherit cmake |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 22 | |
| 23 | # cli11 is a header only C++ library, so the main package will be empty. |
| 24 | RDEPENDS:${PN}-dev = "" |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 25 | |
| 26 | BBCLASSEXTEND = "native nativesdk" |