Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | require cairo.inc |
| 2 | |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=e73e999e0c72b5ac9012424fa157ad77" |
| 4 | |
| 5 | SRC_URI = "http://cairographics.org/releases/cairo-${PV}.tar.xz" |
| 6 | |
| 7 | SRC_URI[md5sum] = "e1cdfaf1c6c995c4d4c54e07215b0118" |
| 8 | SRC_URI[sha256sum] = "c919d999ddb1bbbecd4bbe65299ca2abd2079c7e13d224577895afa7005ecceb" |
| 9 | |
| 10 | PACKAGES =+ "cairo-gobject cairo-script-interpreter cairo-perf-utils" |
| 11 | |
| 12 | SUMMARY_${PN} = "The Cairo 2D vector graphics library" |
| 13 | DESCRIPTION_${PN} = "Cairo is a multi-platform library providing anti-aliased \ |
| 14 | vector-based rendering for multiple target backends. Paths consist \ |
| 15 | of line segments and cubic splines and can be rendered at any width \ |
| 16 | with various join and cap styles. All colors may be specified with \ |
| 17 | optional translucence (opacity/alpha) and combined using the \ |
| 18 | extended Porter/Duff compositing algebra as found in the X Render \ |
| 19 | Extension." |
| 20 | |
| 21 | SUMMARY_cairo-gobject = "The Cairo library GObject wrapper library" |
| 22 | DESCRIPTION_cairo-gobject = "A GObject wrapper library for the Cairo API." |
| 23 | |
| 24 | SUMMARY_cairo-script-interpreter = "The Cairo library script interpreter" |
| 25 | DESCRIPTION_cairo-script-interpreter = "The Cairo script interpreter implements \ |
| 26 | CairoScript. CairoScript is used by tracing utilities to enable the ability \ |
| 27 | to replay rendering." |
| 28 | |
| 29 | DESCRIPTION_cairo-perf-utils = "The Cairo library performance utilities" |
| 30 | |
| 31 | FILES_${PN} = "${libdir}/libcairo.so.*" |
| 32 | FILES_${PN}-dev += "${libdir}/cairo/*.so" |
| 33 | FILES_${PN}-gobject = "${libdir}/libcairo-gobject.so.*" |
| 34 | FILES_${PN}-script-interpreter = "${libdir}/libcairo-script-interpreter.so.*" |
| 35 | FILES_${PN}-perf-utils = "${bindir}/cairo-trace ${libdir}/cairo/*.la ${libdir}/cairo/libcairo-trace.so.*" |
| 36 | |
| 37 | do_install_append () { |
| 38 | rm -rf ${D}${bindir}/cairo-sphinx |
| 39 | rm -rf ${D}${libdir}/cairo/cairo-fdr* |
| 40 | rm -rf ${D}${libdir}/cairo/cairo-sphinx* |
| 41 | rm -rf ${D}${libdir}/cairo/.debug/cairo-fdr* |
| 42 | rm -rf ${D}${libdir}/cairo/.debug/cairo-sphinx* |
| 43 | } |