blob: 156b329486a47b77dde3db5f0f35096a5351c87a [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Common X11 scripts and configuration files"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4SECTION = "x11"
5PR = "r47"
6
7inherit distro_features_check
8# rdepends on xdypinfo xmodmap xinit
9REQUIRED_DISTRO_FEATURES = "x11"
10
11SRC_URI = "file://etc \
12 file://gplv2-license.patch"
13
14S = "${WORKDIR}"
15
16do_install() {
17 cp -R ${S}/etc ${D}${sysconfdir}
18 chmod -R 755 ${D}${sysconfdir}
19 find ${D}${sysconfdir} -type f -name \*~ -exec rm -rf {} \;
20}
21
22RDEPENDS_${PN} = "dbus-x11 xmodmap xdpyinfo xtscal xinit formfactor"
23