Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Common X11 scripts and configuration files" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 4 | SECTION = "x11" |
| 5 | PR = "r47" |
| 6 | |
| 7 | inherit distro_features_check |
| 8 | # rdepends on xdypinfo xmodmap xinit |
| 9 | REQUIRED_DISTRO_FEATURES = "x11" |
| 10 | |
| 11 | SRC_URI = "file://etc \ |
| 12 | file://gplv2-license.patch" |
| 13 | |
| 14 | S = "${WORKDIR}" |
| 15 | |
| 16 | do_install() { |
| 17 | cp -R ${S}/etc ${D}${sysconfdir} |
| 18 | chmod -R 755 ${D}${sysconfdir} |
| 19 | find ${D}${sysconfdir} -type f -name \*~ -exec rm -rf {} \; |
| 20 | } |
| 21 | |
| 22 | RDEPENDS_${PN} = "dbus-x11 xmodmap xdpyinfo xtscal xinit formfactor" |
| 23 | |