Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "Linux user-space application to modify the EFI Boot Manager." |
| 2 | SUMMARY = "EFI Boot Manager" |
| 3 | HOMEPAGE = "https://github.com/rhinstaller/efibootmgr" |
| 4 | SECTION = "base" |
| 5 | |
| 6 | LICENSE = "GPLv2+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" |
| 8 | |
| 9 | DEPENDS = "pciutils zlib efivar" |
| 10 | |
| 11 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 12 | |
| 13 | SRCREV = "a5103251a11663adddc85c86e0b8d3d3b73cbb4a" |
| 14 | SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https \ |
| 15 | " |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit pkgconfig |
| 19 | |
| 20 | EXTRA_OEMAKE = "'EFIDIR=/' 'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/src/include `pkg-config --cflags efivar`'" |
| 21 | |
| 22 | CFLAGS_append_toolchain-clang = " -Wno-error" |
| 23 | do_install () { |
| 24 | install -D -p -m0755 ${B}/src/efibootmgr ${D}/${sbindir}/efibootmgr |
| 25 | } |
| 26 | |
| 27 | CLEANBROKEN = "1" |