Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Manage plain dm-crypt and LUKS encrypted volumes" |
| 2 | DESCRIPTION = "Cryptsetup is used to conveniently setup dm-crypt managed \ |
| 3 | device-mapper mappings. These include plain dm-crypt volumes and \ |
| 4 | LUKS volumes. The difference is that LUKS uses a metadata header \ |
| 5 | and can hence offer more features than plain dm-crypt. On the other \ |
| 6 | hand, the header is visible and vulnerable to damage." |
| 7 | HOMEPAGE = "https://gitlab.com/cryptsetup/cryptsetup" |
| 8 | SECTION = "console" |
| 9 | LICENSE = "GPL-2.0-with-OpenSSL-exception" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=32107dd283b1dfeb66c9b3e6be312326" |
| 11 | |
| 12 | DEPENDS = "util-linux libdevmapper popt libgcrypt json-c" |
| 13 | |
| 14 | SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/v2.0/${BP}.tar.xz" |
| 15 | SRC_URI[md5sum] = "ed42b31f67d05b05e392d1943d467b8d" |
| 16 | SRC_URI[sha256sum] = "9d3a3c7033293e0c97f0ad0501fd5b4d4913ae497cbf70cca06633ccc54b5734" |
| 17 | |
| 18 | inherit autotools gettext pkgconfig |
| 19 | |
| 20 | # Use openssl because libgcrypt drops root privileges |
| 21 | # if libgcrypt is linked with libcap support |
| 22 | PACKAGECONFIG ??= "openssl" |
| 23 | PACKAGECONFIG[openssl] = "--with-crypto_backend=openssl,,openssl" |
| 24 | PACKAGECONFIG[gcrypt] = "--with-crypto_backend=gcrypt,,libgcrypt" |
| 25 | |
| 26 | RRECOMMENDS_${PN} = "kernel-module-aes-generic \ |
| 27 | kernel-module-dm-crypt \ |
| 28 | kernel-module-md5 \ |
| 29 | kernel-module-cbc \ |
| 30 | kernel-module-sha256-generic \ |
| 31 | kernel-module-xts \ |
| 32 | " |
| 33 | |
| 34 | EXTRA_OECONF = "--enable-static" |
| 35 | |
| 36 | FILES_${PN} += "${@bb.utils.contains('DISTRO_FEATURES','systemd','${exec_prefix}/lib/tmpfiles.d/cryptsetup.conf', '', d)}" |
| 37 | |
| 38 | BBCLASSEXTEND = "native nativesdk" |