blob: 70cee849a689f4bbb7ee236ec95634ed1e509bd3 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "The leading native Python SSHv2 protocol library."
2HOMEPAGE = "https://github.com/paramiko/paramiko/"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=fd0120fc2e9f841c73ac707a30389af5"
5
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05006SRC_URI[sha256sum] = "6950faca6819acd3219d4ae694a23c7a87ee38d084f70c1724b0c0dbb8b75769"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007
8PYPI_PACKAGE = "paramiko"
9
10inherit pypi setuptools3
11
12CLEANBROKEN = "1"
13
14RDEPENDS:${PN} += "\
15 ${PYTHON_PN}-bcrypt \
16 ${PYTHON_PN}-cryptography \
17 ${PYTHON_PN}-pynacl \
18 ${PYTHON_PN}-unixadmin \
19"