Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Paho MQTT - C libraries for the MQTT and MQTT-SN protocols" |
| 2 | DESCRIPTION = "Client implementation of open and standard messaging protocols for Machine-to-Machine (M2M) and Internet of Things (IoT)." |
| 3 | HOMEPAGE = "http://www.eclipse.org/paho/" |
| 4 | SECTION = "console/network" |
| 5 | LICENSE = "EPL-2.0 | EDL-1.0" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = " \ |
| 8 | file://edl-v10;md5=3adfcc70f5aeb7a44f3f9b495aa1fbf3 \ |
| 9 | file://epl-v20;md5=d9fc0efef5228704e7f5b37f27192723 \ |
| 10 | file://notice.html;md5=943f861069889acecebf51dfa24478e2 \ |
| 11 | file://about.html;md5=e5662cbb5f8fd5c9faac526e4077898e \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI = "git://github.com/eclipse/paho.mqtt.c;protocol=http;branch=master;protocol=https" |
| 15 | |
Patrick Williams | 4585273 | 2022-04-02 08:58:32 -0500 | [diff] [blame] | 16 | SRCREV = "eff2da4875725509fc97641b118d6badf3e3a08f" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 17 | |
| 18 | DEPENDS = "openssl" |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | inherit cmake |
| 23 | |
| 24 | do_configure:prepend() { |
| 25 | sed -i s:\ lib/cmake:\ ${baselib}/cmake:g ${S}/src/CMakeLists.txt |
| 26 | } |
| 27 | |
| 28 | do_install:append() { |
| 29 | # paho-mqtt installes some thing that we don't want. |
| 30 | rm -rf ${D}${prefix}/samples |
| 31 | find ${D}${prefix} -maxdepth 1 -type f -delete |
| 32 | } |
| 33 | |
| 34 | EXTRA_OECMAKE = "-DPAHO_WITH_SSL=ON" |