Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Protocol Buffers" |
| 2 | HOMEPAGE = "https://developers.google.com/protocol-buffers/" |
| 3 | SECTION = "devel/python" |
| 4 | |
| 5 | LICENSE = "BSD-3-Clause" |
| 6 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=53dbfa56f61b90215a9f8f0d527c043d" |
| 7 | |
| 8 | inherit pypi setuptools3 |
| 9 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 10 | SRC_URI[sha256sum] = "6b1040a5661cd5f6e610cbca9cfaa2a17d60e2bb545309bc1b278bb05be44bdd" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 11 | |
| 12 | # http://errors.yoctoproject.org/Errors/Details/184715/ |
| 13 | # Can't find required file: ../src/google/protobuf/descriptor.proto |
| 14 | CLEANBROKEN = "1" |
| 15 | |
| 16 | UPSTREAM_CHECK_REGEX = "protobuf/(?P<pver>\d+(\.\d+)+)/" |
| 17 | |
| 18 | DEPENDS += "protobuf" |
| 19 | |
| 20 | RDEPENDS:${PN} += " \ |
| 21 | ${PYTHON_PN}-datetime \ |
| 22 | ${PYTHON_PN}-json \ |
| 23 | ${PYTHON_PN}-logging \ |
| 24 | ${PYTHON_PN}-netclient \ |
| 25 | ${PYTHON_PN}-numbers \ |
| 26 | ${PYTHON_PN}-pkgutil \ |
| 27 | ${PYTHON_PN}-six \ |
| 28 | ${PYTHON_PN}-unittest \ |
| 29 | " |
| 30 | |
| 31 | # For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools) |
| 32 | BBCLASSEXTEND = "native nativesdk" |
| 33 | |
| 34 | DISTUTILS_BUILD_ARGS += "--cpp_implementation" |
| 35 | DISTUTILS_INSTALL_ARGS += "--cpp_implementation" |
| 36 | |
| 37 | do_compile:prepend:class-native () { |
| 38 | export KOKORO_BUILD_NUMBER="1" |
| 39 | } |