blob: b84335cf9107d71064820f2ffe0f216c09abac77 [file] [log] [blame]
Joel Stanley34c894e2015-12-06 22:54:23 +10301SUMMARY = "pflash programmer for OpenPower"
2DESCRIPTION = "pflash firmware programming tool for OpenPower machines"
3HOMEPAGE = "https://github.com/open-power"
4LICENSE = "Apache-2.0"
5
6SRC_URI += "git://github.com/open-power/skiboot.git"
7LIC_FILES_CHKSUM = "file://${S}/LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
8
9SRCREV = "6677d2cefb60103156db713e2cdffb02b4a2d270"
10PV = "pflash-git${SRCPV}"
11SRC_URI += "file://0001-pflash-Allow-building-under-yocto.patch"
12
13S = "${WORKDIR}/git"
14
15EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} PFLASH_VERSION=${PV} V=1'
16
17do_compile () {
18 oe_runmake -C external/pflash all
19}
20
21do_install () {
22 oe_runmake -C external/pflash install DESTDIR=${D}
23}