Joel Stanley | 34c894e | 2015-12-06 22:54:23 +1030 | [diff] [blame] | 1 | SUMMARY = "pflash programmer for OpenPower" |
| 2 | DESCRIPTION = "pflash firmware programming tool for OpenPower machines" |
| 3 | HOMEPAGE = "https://github.com/open-power" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | |
| 6 | SRC_URI += "git://github.com/open-power/skiboot.git" |
| 7 | LIC_FILES_CHKSUM = "file://${S}/LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 8 | |
| 9 | SRCREV = "6677d2cefb60103156db713e2cdffb02b4a2d270" |
| 10 | PV = "pflash-git${SRCPV}" |
| 11 | SRC_URI += "file://0001-pflash-Allow-building-under-yocto.patch" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} PFLASH_VERSION=${PV} V=1' |
| 16 | |
| 17 | do_compile () { |
| 18 | oe_runmake -C external/pflash all |
| 19 | } |
| 20 | |
| 21 | do_install () { |
| 22 | oe_runmake -C external/pflash install DESTDIR=${D} |
| 23 | } |