Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Perl interface to the libxml2 library" |
| 2 | DESCRIPTION = "This module is an interface to libxml2, providing XML and HTML parsers \ |
| 3 | with DOM, SAX and XMLReader interfaces, a large subset of DOM Layer 3 \ |
| 4 | interface and a XML::XPath-like interface to XPath API of libxml2. \ |
| 5 | The module is split into several packages which are not described in this \ |
| 6 | section; unless stated otherwise, you only need to use XML::LibXML; in \ |
| 7 | your programs." |
| 8 | |
| 9 | HOMEPAGE = "http://search.cpan.org/dist/XML-LibXML-1.99/" |
| 10 | SECTION = "libs" |
| 11 | LICENSE = "Artistic-1.0|GPLv1+" |
| 12 | DEPENDS += "libxml2 \ |
| 13 | libxml-sax-perl-native \ |
| 14 | zlib \ |
| 15 | " |
| 16 | RDEPENDS_${PN} += "\ |
| 17 | libxml2 \ |
| 18 | libxml-sax-perl \ |
| 19 | libxml-sax-base-perl \ |
| 20 | perl-module-encode \ |
| 21 | perl-module-data-dumper \ |
| 22 | zlib \ |
| 23 | " |
| 24 | |
| 25 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/XML-LibXML-${PV}.tar.gz;name=libxml \ |
| 26 | file://disable-libxml2-check.patch \ |
| 27 | file://fix-CATALOG-conditional-compile.patch \ |
| 28 | file://using-DOCB-conditional.patch \ |
| 29 | " |
| 30 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=64eda1bc135f0ece1d1187f2a8ac82c1 \ |
| 31 | file://LICENSE;md5=97871bde150daeb5e61ad95137ff2446 \ |
| 32 | " |
| 33 | SRC_URI[libxml.md5sum] = "43546fd9a3974f19323f9fb04861ece9" |
| 34 | SRC_URI[libxml.sha256sum] = "721452e3103ca188f5968ab06d5ba29fe8e00e49f4767790882095050312d476" |
| 35 | |
| 36 | S = "${WORKDIR}/XML-LibXML-${PV}" |
| 37 | |
| 38 | inherit cpan |
| 39 | |
| 40 | EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR}/libxml2 LIBS=-L${STAGING_LIBDIR}" |
| 41 | |
| 42 | BBCLASSEXTEND = "native" |
| 43 | |
| 44 | CFLAGS += " -D_GNU_SOURCE " |
| 45 | BUILD_CFLAGS += " -D_GNU_SOURCE " |
| 46 | |
| 47 | FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/XML/LibXML/.debug/" |