Brad Bishop | bec4ebc | 2022-08-03 09:55:16 -0400 | [diff] [blame] | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
| 2 | |
| 3 | # |
| 4 | # Corstone-500 MACHINE |
| 5 | # |
| 6 | SRC_URI:append:corstone500 = " \ |
| 7 | file://0001-armv7-adding-generic-timer-access-through-MMIO.patch \ |
| 8 | file://0002-board-arm-add-corstone500-board.patch" |
| 9 | |
| 10 | # |
| 11 | # Corstone1000 64-bit machines |
| 12 | # |
| 13 | DEPENDS:append:corstone1000 = " gnutls-native" |
| 14 | CORSTONE1000_DEVICE_TREE:corstone1000-mps3 = "corstone1000-mps3" |
| 15 | CORSTONE1000_DEVICE_TREE:corstone1000-fvp = "corstone1000-fvp" |
| 16 | EXTRA_OEMAKE:append:corstone1000 = ' DEVICE_TREE=${CORSTONE1000_DEVICE_TREE}' |
| 17 | |
| 18 | SYSROOT_DIRS:append:corstone1000 = " /boot" |
| 19 | |
| 20 | SRC_URI:append:corstone1000 = " \ |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 21 | file://0001-FF-A-v15-arm64-smccc-add-support-for-SMCCCv1.2-x0-x1.patch \ |
| 22 | file://0002-FF-A-v15-lib-uuid-introduce-uuid_str_to_le_bin-funct.patch \ |
| 23 | file://0003-FF-A-v15-lib-uuid-introduce-testcase-for-uuid_str_to.patch \ |
| 24 | file://0004-FF-A-v15-arm_ffa-introduce-Arm-FF-A-support.patch \ |
| 25 | file://0005-FF-A-v15-arm_ffa-introduce-armffa-command.patch \ |
| 26 | file://0006-FF-A-v15-arm_ffa-introduce-sandbox-FF-A-support.patch \ |
| 27 | file://0007-FF-A-v15-arm_ffa-introduce-sandbox-test-cases-for-UC.patch \ |
| 28 | file://0008-FF-A-v15-arm_ffa-introduce-armffa-command-Sandbox-te.patch \ |
| 29 | file://0009-FF-A-v15-arm_ffa-efi-introduce-FF-A-MM-communication.patch \ |
| 30 | file://0010-FF-A-v15-arm_ffa-efi-corstone1000-enable-MM-communic.patch \ |
| 31 | file://0011-efi-corstone1000-fwu-introduce-EFI-capsule-update.patch \ |
| 32 | file://0012-arm-corstone1000-fix-unrecognized-filesystem-type.patch \ |
| 33 | file://0013-efi_loader-corstone1000-remove-guid-check-from-corst.patch \ |
| 34 | file://0014-efi_loader-populate-ESRT-table-if-EFI_ESRT-config-op.patch \ |
| 35 | file://0015-efi_firmware-add-get_image_info-for-corstone1000.patch \ |
| 36 | file://0016-efi_loader-fix-null-pointer-exception-with-get_image.patch \ |
| 37 | file://0017-arm-corstone1000-add-mmc-for-fvp.patch \ |
| 38 | file://0018-corstone1000-add-compressed-kernel-support.patch \ |
| 39 | file://0019-Introduce-external-sys-driver-to-device-tree.patch \ |
| 40 | file://0020-Add-mhu-and-rpmsg-client-to-u-boot-device-tree.patch \ |
| 41 | file://0021-arm-corstone1000-esrt-support.patch \ |
| 42 | file://0022-corstone1000-enable-distro-booting-command.patch \ |
| 43 | file://0023-corstone1000-add-fwu-metadata-store-info.patch \ |
| 44 | file://0024-fwu_metadata-make-sure-structures-are-packed.patch \ |
| 45 | file://0025-corstone1000-add-boot-index.patch \ |
| 46 | file://0026-corstone1000-adjust-boot-bank-and-kernel-location.patch \ |
| 47 | file://0027-corstone1000-add-nvmxip-fwu-mdata-and-gpt-options.patch \ |
| 48 | file://0028-nvmxip-move-header-to-include.patch \ |
| 49 | file://0029-corstone1000-set-kernel_addr-based-on-boot_idx.patch \ |
| 50 | file://0030-corstone1000-boot-index-from-active.patch \ |
| 51 | file://0031-corstone1000-enable-PSCI-reset.patch \ |
| 52 | file://0032-Enable-EFI-set-get-time-services.patch \ |
| 53 | file://0033-Increase-the-unzipped-Kernel-size.patch \ |
Patrick Williams | 975a06f | 2022-10-21 14:42:47 -0500 | [diff] [blame] | 54 | " |
Brad Bishop | bec4ebc | 2022-08-03 09:55:16 -0400 | [diff] [blame] | 55 | |
| 56 | # |
| 57 | # FVP BASE |
| 58 | # |
Andrew Geissler | 2daf84b | 2023-03-31 09:57:23 -0500 | [diff] [blame] | 59 | SRC_URI:append:fvp-base = " file://bootargs.cfg \ |
| 60 | file://0001-Revert-vexpress64-pick-DRAM-size-from-DT.patch \ |
| 61 | " |
Brad Bishop | bec4ebc | 2022-08-03 09:55:16 -0400 | [diff] [blame] | 62 | |
| 63 | # |
| 64 | # FVP BASER |
| 65 | # |
| 66 | SRC_URI:append:fvp-baser-aemv8r64 = " \ |
| 67 | file://0001-armv8-Add-ARMv8-MPU-configuration-logic.patch \ |
| 68 | file://0002-vexpress64-add-MPU-memory-map-for-the-BASER_FVP.patch \ |
| 69 | file://0003-armv8-Allow-disabling-exception-vectors-on-non-SPL-b.patch \ |
| 70 | file://0004-armv8-ARMV8_SWITCH_TO_EL1-improvements.patch \ |
| 71 | file://0005-armv8-Make-disabling-HVC-configurable-when-switching.patch \ |
| 72 | file://0006-vexpress64-Do-not-set-COUNTER_FREQUENCY.patch \ |
| 73 | file://0007-vexpress64-Enable-LIBFDT_OVERLAY-in-the-vexpress_aem.patch \ |
| 74 | file://0008-armv8-Allow-PRBAR-MPU-attributes-to-be-configured.patch \ |
| 75 | file://0009-armv8-Enable-icache-when-switching-exception-levels-.patch \ |
| 76 | " |
| 77 | |
| 78 | |
| 79 | # |
| 80 | # Juno Machines |
| 81 | # |
Patrick Williams | b9af875 | 2023-01-30 13:28:01 -0600 | [diff] [blame] | 82 | SRC_URI:append:juno = " file://0001-configs-vexpress-modify-to-boot-compressed-initramfs.patch" |
Brad Bishop | bec4ebc | 2022-08-03 09:55:16 -0400 | [diff] [blame] | 83 | |
| 84 | |
| 85 | # |
| 86 | # TC0 and TC1 MACHINES |
| 87 | # |
| 88 | SRC_URI:append:tc = " \ |
| 89 | file://bootargs.cfg \ |
Brad Bishop | bec4ebc | 2022-08-03 09:55:16 -0400 | [diff] [blame] | 90 | " |