blob: 2c7a9f8cabb76608b06ac8d19033a64cd43dad20 [file] [log] [blame]
Patrick Williams73bd93f2024-02-20 08:07:48 -06001SUMMARY = "High level compatibility layer for multiple asynchronous event loop implementations"
2SECTION = "devel/python"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=c0a769411d2af7894099e8ff75058c9f"
5
6inherit pypi python_setuptools_build_meta
7
Patrick Williams03514f12024-04-05 07:04:11 -05008SRC_URI[sha256sum] = "f75253795a87df48568485fd18cdd2a3fa5c4f7c5be8e5e36637733fce06fed6"
Patrick Williams73bd93f2024-02-20 08:07:48 -06009
10DEPENDS += " \
11 python3-setuptools-scm-native \
12"
13
14# Don't provide "trio" PACKAGECONFIG as nothing provides "python3-trio" currently.
15# If somebody needs this please feel free to add python3-trio and enable the
16# packageconfig below:
17#PACKAGECONFIG ??= ""
18#PACKAGECONFIG[trio] = ",,,python3-trio"
19
20RDEPENDS:${PN} += "\
21 python3-idna \
22 python3-sniffio \
Patrick Williams03514f12024-04-05 07:04:11 -050023 python3-core \
24 python3-numbers \
25 python3-io \
26 python3-asyncio \
Patrick Williams73bd93f2024-02-20 08:07:48 -060027"