Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "System load testing utility" |
| 2 | DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \ |
| 3 | imposes a configurable amount of CPU, memory, I/O, and disk stress on the system." |
| 4 | HOMEPAGE = "https://github.com/ColinIanKing/stress-ng#readme" |
| 5 | LICENSE = "GPL-2.0-only" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 8 | SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https;branch=master \ |
| 9 | file://0001-Makefile-quote-CC.patch \ |
| 10 | " |
| 11 | SRCREV = "ec7f6c4731a54f0e515bef7f7e84ef9e9b8125a2" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | DEPENDS = "coreutils-native" |
| 15 | |
| 16 | PROVIDES = "stress" |
| 17 | RPROVIDES:${PN} = "stress" |
| 18 | RREPLACES:${PN} = "stress" |
| 19 | RCONFLICTS:${PN} = "stress" |
| 20 | |
| 21 | inherit bash-completion |
| 22 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 23 | do_configure:prepend() { |
| 24 | mkdir -p configs |
| 25 | touch configs/HAVE_APPARMOR |
| 26 | } |
| 27 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 28 | do_install() { |
| 29 | oe_runmake DESTDIR=${D} install |
| 30 | ln -s stress-ng ${D}${bindir}/stress |
| 31 | } |