Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "gvfs is a userspace virtual filesystem" |
| 2 | LICENSE = "LGPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=05df38dd77c35ec8431f212410a3329e" |
| 4 | |
| 5 | GNOMEBASEBUILDCLASS = "meson" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 6 | inherit gnomebase gsettings bash-completion gettext upstream-version-is-even features_check useradd |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 7 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 8 | DEPENDS += "libsecret glib-2.0 glib-2.0-native libgudev shadow-native \ |
| 9 | gsettings-desktop-schemas dbus" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | |
| 11 | SRC_URI = "https://download.gnome.org/sources/${BPN}/${@gnome_verdir("${PV}")}/${BPN}-${PV}.tar.xz;name=archive" |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 12 | SRC_URI[archive.md5sum] = "72383474f52d05c21ef2be96d0b91974" |
| 13 | SRC_URI[archive.sha256sum] = "50ef3245d1b03666a40455109169a2a1bd51419fd2d51f9fa6cfd4f89f04fb46" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 15 | # depends on gsettings-desktop-schemas->gcr->gtk+3-> x11 |
| 16 | REQUIRED_DISTRO_FEATURES = "x11" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 17 | |
| 18 | EXTRA_OEMESON = " \ |
| 19 | -Dbluray=false \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 20 | -Dgoa=false \ |
| 21 | -Dgoogle=false \ |
| 22 | -Dnfs=false \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 23 | " |
| 24 | |
| 25 | PACKAGES =+ "gvfsd-ftp gvfsd-sftp gvfsd-trash" |
| 26 | |
| 27 | FILES_${PN} += " \ |
| 28 | ${datadir}/glib-2.0 \ |
| 29 | ${datadir}/GConf \ |
| 30 | ${datadir}/dbus-1/services \ |
| 31 | ${libdir}/gio/modules/*.so \ |
| 32 | ${libdir}/tmpfiles.d \ |
| 33 | ${systemd_user_unitdir} \ |
| 34 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 35 | |
| 36 | FILES_${PN}-dbg += "${libdir}/gio/modules/.debug/*" |
| 37 | FILES_${PN}-dev += "${libdir}/gio/modules/*.la" |
| 38 | |
| 39 | FILES_gvfsd-ftp = "${libexecdir}/gvfsd-ftp ${datadir}/gvfs/mounts/ftp.mount" |
| 40 | FILES_gvfsd-sftp = "${libexecdir}/gvfsd-sftp ${datadir}/gvfs/mounts/sftp.mount" |
| 41 | FILES_gvfsd-trash = "${libexecdir}/gvfsd-trash ${datadir}/gvfs/mounts/trash.mount" |
| 42 | |
| 43 | RRECOMMENDS_gvfsd-ftp += "openssh-sftp openssh-ssh" |
| 44 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 45 | PACKAGECONFIG ?= "libgphoto2 \ |
| 46 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
| 47 | ${@bb.utils.contains('DISTRO_FEATURES','polkit','udisks2','',d)} \ |
| 48 | ${@bb.utils.contains('DISTRO_FEATURES','polkit','admin','',d)} \ |
| 49 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 50 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 51 | PACKAGECONFIG[udisks2] = "-Dudisks2=true, -Dudisks2=false, udisks2, udisks2" |
| 52 | PACKAGECONFIG[admin] = "-Dadmin=true, -Dadmin=false, libcap polkit" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 53 | PACKAGECONFIG[afc] = "-Dafc=true, -Dafc=false, libimobiledevice libplist" |
| 54 | PACKAGECONFIG[archive] = "-Darchive=true, -Darchive=false, libarchive" |
| 55 | PACKAGECONFIG[dnssd] = "-Ddnssd=true, -Ddnssd=false, avahi" |
| 56 | PACKAGECONFIG[gcr] = "-Dgcr=true, -Dgcr=false, gcr" |
| 57 | PACKAGECONFIG[http] = "-Dhttp=true, -Dhttp=false, libsoup-2.4" |
| 58 | PACKAGECONFIG[libmtp] = "-Dmtp=true, -Dmtp=false, libmtp" |
| 59 | PACKAGECONFIG[logind] = "-Dlogind=true, -Dlogind=false, systemd" |
| 60 | PACKAGECONFIG[libgphoto2] = "-Dgphoto2=true, -Dgphoto2=false, libgphoto2" |
| 61 | PACKAGECONFIG[samba] = "-Dsmb=true, -Dsmb=false, samba" |
| 62 | PACKAGECONFIG[systemd] = "-Dsystemduserunitdir=${systemd_user_unitdir} -Dtmpfilesdir=${libdir}/tmpfiles.d, -Dsystemduserunitdir=no -Dtmpfilesdir=no, systemd" |
| 63 | |
| 64 | # needs meta-filesystems |
| 65 | PACKAGECONFIG[fuse] = "-Dfuse=true, -Dfuse=false, fuse" |
| 66 | |
| 67 | # libcdio-paranoia recipe doesn't exist yet |
| 68 | PACKAGECONFIG[cdda] = "-Dcdda=true, -Dcdda=false, libcdio-paranoia" |
| 69 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 70 | USERADD_PACKAGES = "${PN}" |
| 71 | USERADD_PARAM_${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/${BPN}-1 polkitd" |
| 72 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 73 | do_install_append() { |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 74 | if ${@bb.utils.contains('DISTRO_FEATURES', 'polkit', 'true', 'false', d)}; then |
| 75 | # Fix up permissions on polkit rules.d to work with rpm4 constraints |
| 76 | chmod 700 ${D}/${datadir}/polkit-1/rules.d |
| 77 | chown polkitd:root ${D}/${datadir}/polkit-1/rules.d |
| 78 | fi |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 79 | |
| 80 | # After rebuilds (not from scracth) it can happen that the executables in |
| 81 | # libexec ar missing executable permission flag. Not sure but it came up |
| 82 | # during transition to meson. Looked into build files and logs but could |
| 83 | # not find suspicious |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 84 | for exe in `find ${D}/${libexecdir}`; do |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 85 | chmod +x $exe |
| 86 | done |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 87 | } |