blob: 4c3177c05f7157cf4605aa36eb2a39337f1797ff [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "display dialog boxes from shell scripts"
2DESCRIPTION = "Dialog lets you to present a variety of questions \
3or display messages using dialog boxes from a shell \
4script (or any scripting language)."
5HOMEPAGE = "http://invisible-island.net/dialog/"
6SECTION = "console/utils"
7DEPENDS = "ncurses"
8LICENSE = "LGPL-2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
10
11SRC_URI = "ftp://ftp.invisible-island.net/${BPN}/${BP}.tgz \
12 "
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050013SRC_URI[md5sum] = "f7a3c240af305b5282af590541e8f4b7"
14SRC_URI[sha256sum] = "466163e8b97c2b7709d00389199add3156bd813f60ccb0335d0a30f2d4a17f99"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015
16# hardcoded here for use in dialog-static recipe
17S = "${WORKDIR}/dialog-${PV}"
18
19inherit autotools-brokensep pkgconfig
20
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050021PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
22
23PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--without-x,virtual/libx11"
24
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025EXTRA_OECONF = "--with-ncurses \
26 --disable-rpath-hack"
27
28do_configure() {
29 gnu-configize --force
30 sed -i 's,${cf_ncuconfig_root}6-config,${cf_ncuconfig_root}-config,g' -i configure
31 sed -i 's,cf_have_ncuconfig=unknown,cf_have_ncuconfig=yes,g' -i configure
32 oe_runconf
33}