Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame^] | 1 | require openssl.inc |
| 2 | |
| 3 | # For target side versions of openssl enable support for OCF Linux driver |
| 4 | # if they are available. |
| 5 | DEPENDS += "cryptodev-linux" |
| 6 | |
| 7 | CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8" |
| 10 | |
| 11 | export DIRS = "crypto ssl apps engines" |
| 12 | export OE_LDFLAGS="${LDFLAGS}" |
| 13 | |
| 14 | SRC_URI += "file://configure-targets.patch \ |
| 15 | file://shared-libs.patch \ |
| 16 | file://oe-ldflags.patch \ |
| 17 | file://engines-install-in-libdir-ssl.patch \ |
| 18 | file://debian1.0.2/block_diginotar.patch \ |
| 19 | file://debian1.0.2/block_digicert_malaysia.patch \ |
| 20 | file://debian/ca.patch \ |
| 21 | file://debian/c_rehash-compat.patch \ |
| 22 | file://debian/debian-targets.patch \ |
| 23 | file://debian/man-dir.patch \ |
| 24 | file://debian/man-section.patch \ |
| 25 | file://debian/no-rpath.patch \ |
| 26 | file://debian/no-symbolic.patch \ |
| 27 | file://debian/pic.patch \ |
| 28 | file://debian/version-script.patch \ |
| 29 | file://openssl_fix_for_x32.patch \ |
| 30 | file://fix-cipher-des-ede3-cfb1.patch \ |
| 31 | file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \ |
| 32 | file://find.pl \ |
| 33 | file://openssl-fix-des.pod-error.patch \ |
| 34 | file://Makefiles-ptest.patch \ |
| 35 | file://ptest-deps.patch \ |
| 36 | file://run-ptest \ |
| 37 | file://crypto_use_bigint_in_x86-64_perl.patch \ |
| 38 | file://openssl-1.0.2a-x32-asm.patch \ |
| 39 | " |
| 40 | |
| 41 | SRC_URI[md5sum] = "38dd619b2e77cbac69b99f52a053d25a" |
| 42 | SRC_URI[sha256sum] = "671c36487785628a703374c652ad2cebea45fa920ae5681515df25d9f2c9a8c8" |
| 43 | |
| 44 | PACKAGES =+ " \ |
| 45 | ${PN}-engines \ |
| 46 | ${PN}-engines-dbg \ |
| 47 | " |
| 48 | |
| 49 | FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines" |
| 50 | FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug" |
| 51 | |
| 52 | PARALLEL_MAKE = "" |
| 53 | PARALLEL_MAKEINST = "" |
| 54 | |
| 55 | do_configure_prepend() { |
| 56 | cp ${WORKDIR}/find.pl ${S}/util/find.pl |
| 57 | } |