Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame^] | 1 | SUMMARY = "A library for text mode user interfaces" |
| 2 | |
| 3 | DESCRIPTION = "Newt is a programming library for color text mode, widget based user \ |
| 4 | interfaces. Newt can be used to add stacked windows, entry widgets, \ |
| 5 | checkboxes, radio buttons, labels, plain text fields, scrollbars, \ |
| 6 | etc., to text mode user interfaces. This package also contains the \ |
| 7 | shared library needed by programs built with newt, as well as a \ |
| 8 | /usr/bin/dialog replacement called whiptail. Newt is based on the \ |
| 9 | slang library." |
| 10 | |
| 11 | HOMEPAGE = "https://fedorahosted.org/newt/" |
| 12 | SECTION = "libs" |
| 13 | |
| 14 | LICENSE = "LGPLv2" |
| 15 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 16 | |
| 17 | # slang needs to be >= 2.2 |
| 18 | DEPENDS = "slang popt" |
| 19 | |
| 20 | SRC_URI = "https://fedorahosted.org/releases/n/e/newt/newt-${PV}.tar.gz \ |
| 21 | file://remove_slang_include.patch \ |
| 22 | file://fix_SHAREDDIR.patch \ |
| 23 | file://cross_ar.patch \ |
| 24 | " |
| 25 | |
| 26 | SRC_URI[md5sum] = "685721bee1a318570704b19dcf31d268" |
| 27 | SRC_URI[sha256sum] = "771b0e634ede56ae6a6acd910728bb5832ac13ddb0d1d27919d2498dab70c91e" |
| 28 | |
| 29 | S = "${WORKDIR}/newt-${PV}" |
| 30 | |
| 31 | EXTRA_OECONF = "--without-tcl --without-python" |
| 32 | |
| 33 | inherit autotools-brokensep |
| 34 | |
| 35 | CLEANBROKEN = "1" |
| 36 | |
| 37 | export STAGING_INCDIR |
| 38 | export STAGING_LIBDIR |
| 39 | |
| 40 | export BUILD_SYS |
| 41 | export HOST_SYS |
| 42 | |
| 43 | PACKAGES_prepend = "whiptail " |
| 44 | |
| 45 | do_configure_prepend() { |
| 46 | sh autogen.sh |
| 47 | } |
| 48 | |
| 49 | do_compile_prepend() { |
| 50 | # Make sure the recompile is OK |
| 51 | rm -f ${B}/.depend |
| 52 | } |
| 53 | |
| 54 | FILES_whiptail = "${bindir}/whiptail" |
| 55 | |
| 56 | BBCLASSEXTEND = "native" |