Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame^] | 1 | SUMMARY = "Utilities for extracting and viewing files in .zip archives" |
| 2 | HOMEPAGE = "http://www.info-zip.org" |
| 3 | SECTION = "console/utils" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=94caec5a51ef55ef711ee4e8b1c69e29" |
| 6 | PE = "1" |
| 7 | PR = "r5" |
| 8 | |
| 9 | SRC_URI = "ftp://ftp.info-zip.org/pub/infozip/src/unzip60.tgz \ |
| 10 | file://avoid-strip.patch \ |
| 11 | file://define-ldflags.patch \ |
| 12 | file://06-unzip60-alt-iconv-utf8_CVE-2015-1315.patch \ |
| 13 | file://unzip-6.0_overflow3.diff \ |
| 14 | file://09-cve-2014-8139-crc-overflow.patch \ |
| 15 | file://10-cve-2014-8140-test-compr-eb.patch \ |
| 16 | file://11-cve-2014-8141-getzip64data.patch \ |
| 17 | " |
| 18 | |
| 19 | SRC_URI[md5sum] = "62b490407489521db863b523a7f86375" |
| 20 | SRC_URI[sha256sum] = "036d96991646d0449ed0aa952e4fbe21b476ce994abc276e49d30e686708bd37" |
| 21 | S = "${WORKDIR}/unzip60" |
| 22 | |
| 23 | # Makefile uses CF_NOOPT instead of CFLAGS. We lifted the values from |
| 24 | # Makefile and add CFLAGS. Optimization will be overriden by unzip |
| 25 | # configure to be -O3. |
| 26 | # |
| 27 | EXTRA_OEMAKE += "STRIP=true LF2='' \ |
| 28 | 'CF_NOOPT=-I. -Ibzip2 -DUNIX ${CFLAGS}'" |
| 29 | |
| 30 | export LD = "${CC}" |
| 31 | LD_class-native = "${CC}" |
| 32 | |
| 33 | do_compile() { |
| 34 | oe_runmake -f unix/Makefile generic |
| 35 | } |
| 36 | |
| 37 | do_install() { |
| 38 | oe_runmake -f unix/Makefile install prefix=${D}${prefix} |
| 39 | install -d ${D}${mandir} |
| 40 | mv ${D}${prefix}/man/* ${D}${mandir} |
| 41 | rmdir ${D}${prefix}/man/ |
| 42 | } |
| 43 | |
| 44 | inherit update-alternatives |
| 45 | |
| 46 | ALTERNATIVE_PRIORITY = "100" |
| 47 | |
| 48 | ALTERNATIVE_${PN} = "unzip" |
| 49 | ALTERNATIVE_LINK_NAME[unzip] = "${bindir}/unzip" |
| 50 | |
| 51 | BBCLASSEXTEND = "native" |