Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame^] | 1 | SUMMARY = "Wayland, a protocol between a compositor and clients" |
| 2 | DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \ |
| 3 | as well as a C library implementation of that protocol. The compositor can be \ |
| 4 | a standalone display server running on Linux kernel modesetting and evdev \ |
| 5 | input devices, an X application, or a wayland client itself. The clients can \ |
| 6 | be traditional applications, X servers (rootless or fullscreen) or other \ |
| 7 | display servers." |
| 8 | HOMEPAGE = "http://wayland.freedesktop.org" |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=1d4476a7d98dd5691c53d4d43a510c72 \ |
| 11 | file://src/wayland-server.c;endline=21;md5=079ae21dbf98ada52ec23744851b0a5c" |
| 12 | |
| 13 | SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ |
| 14 | file://always-build-scanner.patch" |
| 15 | SRC_URI[md5sum] = "6e877877c3e04cfb865cfcd0733c9ab1" |
| 16 | SRC_URI[sha256sum] = "f17c938d1c24fd0a10f650a623a2775d329db3168b5732e498b08388ec776fc8" |
| 17 | |
| 18 | SRC_URI_append_class-native = " \ |
| 19 | file://disable-macro-checks-not-used-for-scanner.patch \ |
| 20 | " |
| 21 | EXTRA_OECONF_class-native = "--disable-documentation" |
| 22 | |
| 23 | inherit autotools pkgconfig |
| 24 | |
| 25 | BBCLASSEXTEND = "native nativesdk" |
| 26 | |
| 27 | DEPENDS = "expat libffi wayland-native" |
| 28 | |
| 29 | EXTRA_OECONF = "--disable-documentation --with-host-scanner" |
| 30 | |
| 31 | # Wayland installs a M4 macro for other projects to use, which uses the target |
| 32 | # pkg-config to find files. Replace pkg-config with pkg-config-native. |
| 33 | do_install_append_class-native() { |
| 34 | sed -e 's,PKG_CHECK_MODULES(.*),,g' \ |
| 35 | -e 's,$PKG_CONFIG,pkg-config-native,g' \ |
| 36 | -i ${D}/${datadir}/aclocal/wayland-scanner.m4 |
| 37 | } |
| 38 | |
| 39 | sysroot_stage_all_append_class-target () { |
| 40 | rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4 |
| 41 | cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/ |
| 42 | } |
| 43 | |
| 44 | FILES_${PN} = "${libdir}/*${SOLIBS}" |
| 45 | FILES_${PN}-dev += "${bindir} ${datadir}/wayland" |