Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame^] | 1 | SUMMARY = "Custom Matchbox session files for the Sato environment" |
| 2 | HOMEPAGE = "http://www.matchbox-project.org/" |
| 3 | BUGTRACKER = "http://bugzilla.yoctoproject.org/" |
| 4 | |
| 5 | LICENSE = "GPLv2.0+" |
| 6 | LIC_FILES_CHKSUM = "file://session;endline=3;md5=f8a5c5b9c279e52dc094d10e11c2be63" |
| 7 | |
| 8 | SECTION = "x11" |
| 9 | DEPENDS = "gconf-native" |
| 10 | RDEPENDS_${PN} = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato matchbox-session gconf" |
| 11 | PR = "r30" |
| 12 | |
| 13 | # This package is architecture specific because the session script is modified |
| 14 | # based on the machine architecture. |
| 15 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 16 | |
| 17 | inherit distro_features_check |
| 18 | |
| 19 | # The matchbox-theme-sato requires x11 in DISTRO_FEATURES |
| 20 | REQUIRED_DISTRO_FEATURES = "x11" |
| 21 | |
| 22 | SRC_URI = "file://session" |
| 23 | S = "${WORKDIR}" |
| 24 | |
| 25 | do_install() { |
| 26 | # This is the set of machine features that the script has markers for |
| 27 | FEATURES="phone" |
| 28 | SCRIPT="${S}/sedder" |
| 29 | rm -f $SCRIPT |
| 30 | touch $SCRIPT |
| 31 | for FEAT in $FEATURES; do |
| 32 | if echo ${MACHINE_FEATURES} | awk "/$FEAT/ {exit 1}"; then |
| 33 | echo "/feature-$FEAT/d" >> $SCRIPT |
| 34 | fi |
| 35 | done |
| 36 | |
| 37 | install -d ${D}/${sysconfdir}/matchbox |
| 38 | sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session |
| 39 | chmod +x ${D}/${sysconfdir}/matchbox/session |
| 40 | } |
| 41 | |
| 42 | pkg_postinst_${PN} () { |
| 43 | set_value() { |
| 44 | #type, name, value |
| 45 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type $1 --set /desktop/poky/interface/$2 "$3" |
| 46 | } |
| 47 | set_value string theme Sato |
| 48 | set_value string icon_theme Sato |
| 49 | set_value bool touchscreen true |
| 50 | set_value string font_name "Sans 9" |
| 51 | } |