Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame^] | 1 | SUMMARY = "AT-SPI 2 Toolkit Bridge" |
| 2 | LICENSE = "LGPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=e9f288ba982d60518f375b5898283886" |
| 4 | |
| 5 | MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}" |
| 6 | |
| 7 | SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz" |
| 8 | SRC_URI[md5sum] = "8936488c8cdce0e158f80b2e247527f9" |
| 9 | SRC_URI[sha256sum] = "78efc45ec36383bf785f8636e64a8d866defeb020e00a08f92978f1fc3772ff9" |
| 10 | |
| 11 | DEPENDS = "dbus glib-2.0 atk at-spi2-core" |
| 12 | |
| 13 | inherit autotools pkgconfig distro_features_check |
| 14 | |
| 15 | # The at-spi2-core requires x11 in DISTRO_FEATURES |
| 16 | REQUIRED_DISTRO_FEATURES = "x11" |
| 17 | |
| 18 | PACKAGES =+ "${PN}-gnome ${PN}-gtk2" |
| 19 | |
| 20 | FILES_${PN}-gnome = "${libdir}/gnome-settings-daemon-3.0/gtk-modules" |
| 21 | FILES_${PN}-gtk2 = "${libdir}/gtk-2.0/modules/libatk-bridge.*" |
| 22 | FILES_${PN}-dbg += "${libdir}/gtk-2.0/modules/.debug" |