Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Control process attributes through prctl" |
| 2 | DESCRIPTION = "The linux prctl function allows you to control specific characteristics of a \ |
| 3 | process' behaviour. Usage of the function is fairly messy though, due to \ |
| 4 | limitations in C and linux. This module provides a nice non-messy python(ic) \ |
| 5 | interface." |
| 6 | SECTION = "devel/python" |
| 7 | LICENSE = "GPLv3" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=23ff9f50449d4bd0e513df16e4d9755f" |
| 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | B = "${S}" |
| 12 | |
| 13 | SRCREV = "57cd0a7cad76e8f8792eea22ee5b5d17bae0a90f" |
| 14 | PV = "1.7+git${SRCPV}" |
| 15 | |
| 16 | SRC_URI = "git://github.com/seveas/python-prctl;branch=master \ |
| 17 | file://0001-support-cross-complication.patch \ |
| 18 | " |
| 19 | inherit setuptools3 python3native |
| 20 | |
| 21 | DEPENDS += "libcap" |
| 22 | |