Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright (C) 2012 Wind River Systems, Inc. |
| 3 | # |
| 4 | SUMMARY = "Provides a wrapper in Python to LDAP" |
| 5 | DESCRIPTION = "This module provides access to the LDAP \ |
| 6 | (Lightweight Directory Access Protocol) through Python operations \ |
| 7 | instead of C API. The module mainly acts as a wrapper for the \ |
| 8 | OpenLDAP 2.x libraries. Errors will appear as exceptions." |
| 9 | |
| 10 | LICENSE = "PSF" |
| 11 | HOMEPAGE = "http://www.python-ldap.org/" |
| 12 | DEPENDS = "python3 openldap cyrus-sasl" |
| 13 | |
| 14 | PYPI_PACKAGE = "python-ldap" |
| 15 | inherit pypi setuptools3 |
| 16 | |
| 17 | LIC_FILES_CHKSUM = "file://LICENCE;md5=36ce9d726d0321b73c1521704d07db1b" |
Andrew Geissler | 72956ed | 2021-01-08 16:11:14 -0600 | [diff] [blame] | 18 | SRC_URI[md5sum] = "7608579722c491e42f5f63b3f88a95fb" |
| 19 | SRC_URI[sha256sum] = "4711cacf013e298754abd70058ccc995758177fb425f1c2d30e71adfc1d00aa5" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 21 | do_configure:prepend() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | sed -i -e 's:^library_dirs =.*::' ${S}/setup.cfg |
| 23 | sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' ${S}/setup.cfg |
| 24 | } |
| 25 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | RDEPENDS:${PN} = " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 27 | ${PYTHON_PN}-pprint \ |
| 28 | ${PYTHON_PN}-threading \ |
| 29 | ${PYTHON_PN}-pyasn1 \ |
| 30 | ${PYTHON_PN}-pyasn1-modules \ |
| 31 | " |