blob: 04dcac30d99aa9ca2712fe3d3ccd0777a33fd858 [file] [log] [blame]
Delphine CC Chiu99be5bc32023-12-11 13:56:32 +08001FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
2
3
4SRC_URI += " \
5 file://setup-local-eid.conf \
Chris Wang062def22024-04-10 16:35:42 +08006 file://setup-static-endpoints.conf \
Delphine CC Chiu99be5bc32023-12-11 13:56:32 +08007 file://mctp-config.sh \
Chris Wang062def22024-04-10 16:35:42 +08008 file://setup-static-endpoints.sh \
Delphine CC Chiu99be5bc32023-12-11 13:56:32 +08009"
10
11FILES:${PN} += "${systemd_system_unitdir}/*"
12
13do_install:append () {
14 override_dir=${D}${systemd_system_unitdir}/mctpd.service.d
15 install -d ${D}${systemd_system_unitdir}/mctpd.service.d
16 install -d ${D}${datadir}/mctp
17 install -m 0644 ${WORKDIR}/setup-local-eid.conf \
18 ${override_dir}/setup-local-eid.conf
Chris Wang062def22024-04-10 16:35:42 +080019 install -m 0644 ${WORKDIR}/setup-static-endpoints.conf \
20 ${override_dir}/setup-static-endpoints.conf
Delphine CC Chiu99be5bc32023-12-11 13:56:32 +080021 install -m 0755 ${WORKDIR}/mctp-config.sh \
22 ${D}${datadir}/mctp/
Chris Wang062def22024-04-10 16:35:42 +080023 install -m 0755 ${WORKDIR}/setup-static-endpoints.sh \
24 ${D}${datadir}/mctp/
Delphine CC Chiu99be5bc32023-12-11 13:56:32 +080025}