Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 1 | SUMMARY = "Simple program to read/write from/to any location in memory" |
| 2 | LICENSE = "GPL-2.0-or-later" |
| 3 | LIC_FILES_CHKSUM = "file://devmem2.c;endline=38;md5=a9eb9f3890384519f435aedf986297cf" |
| 4 | |
| 5 | SRC_URI = "git://github.com/denix0/devmem2.git;protocol=https;branch=main" |
| 6 | SRCREV = "5b395a946894eb4f4ef5d07c80a50a88573a541e" |
| 7 | |
| 8 | S = "${WORKDIR}/git" |
| 9 | |
| 10 | CFLAGS += "-DFORCE_STRICT_ALIGNMENT" |
| 11 | |
| 12 | do_compile() { |
| 13 | ${CC} -o devmem2 devmem2.c ${CFLAGS} ${LDFLAGS} |
| 14 | } |
| 15 | |
| 16 | do_install() { |
| 17 | install -d ${D}${bindir} |
| 18 | install devmem2 ${D}${bindir} |
| 19 | } |