blob: bcd309282b9613dfc456efd3579f3e885057a379 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "TinyXML-2 is a simple, small, efficient, C++ XML parser that can be easily integrating into other programs"
Patrick Williams73bd93f2024-02-20 08:07:48 -06002HOMEPAGE = "https://leethomason.github.io/tinyxml2"
Andrew Geissler82c905d2020-04-13 13:39:40 -05003SECTION = "libs"
4LICENSE = "Zlib"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=135624eef03e1f1101b9ba9ac9b5fffd"
6
Patrick Williams705982a2024-01-12 09:51:57 -06007SRCREV = "321ea883b7190d4e85cae5512a12e5eaa8f8731f"
Patrick Williams8e7b46e2023-05-01 14:19:06 -05008SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https \
9 file://run-ptest"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
11S = "${WORKDIR}/git"
12
Patrick Williams8e7b46e2023-05-01 14:19:06 -050013inherit meson ptest
14
Patrick Williams73bd93f2024-02-20 08:07:48 -060015EXTRA_OEMESON += " \
16 ${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true', '', d)} \
17 -Ddefault_library=both \
18"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050019
20CXXFLAGS:append:libc-musl = " -D_LARGEFILE64_SOURCE"
21
22do_install_ptest() {
23 install -Dm 0755 ${B}/xmltest ${D}${PTEST_PATH}/xmltest
24 install -d ${D}${PTEST_PATH}/resources/out
Patrick Williams705982a2024-01-12 09:51:57 -060025 for f in ${S}/resources/*.xml; do
26 install -m 0644 $f ${D}${PTEST_PATH}/resources/
27 done
Patrick Williams8e7b46e2023-05-01 14:19:06 -050028}
Andrew Geissler82c905d2020-04-13 13:39:40 -050029
Patrick Williams03514f12024-04-05 07:04:11 -050030BBCLASSEXTEND = "native nativesdk"