blob: 8888b226780be83e9edd22a344c2ffe1a5752f4e [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Analyze Suspend"
2DESCRIPTION = "analyze-suspend is a tool for system developers to visualize \
3the activity between suspend and resume, allowing them to identify \
4inefficiencies and bottlenecks."
5HOMEPAGE = "https://01.org/suspendresume"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
9# Apart from the listed RDEPENDS, analyze-suspend depends on some features
10# provided by the kernel. These options are:
11# - CONFIG_PM_DEBUG=y
12# - CONFIG_PM_SLEEP_DEBUG=y
13# - CONFIG_FTRACE=y
14# - CONFIG_FUNCTION_TRACER=y
15# - CONFIG_FUNCTION_GRAPH_TRACER=y
16
17RDEPENDS_${PN} += "python-core python-datetime python-stringold"
18
19PV = "3.2+gitr${SRCPV}"
Patrick Williamsddad1a12017-02-23 20:36:32 -060020SRCREV = "c669e002a2e7504f21e277ad248fa81033926391"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050021SRC_URI = "git://github.com/01org/suspendresume.git;protocol=https"
22S = "${WORKDIR}/git"
23
24do_install() {
Patrick Williamsddad1a12017-02-23 20:36:32 -060025 install -Dm 0755 analyze_suspend.py ${D}${bindir}/analyze_suspend.py
26 install -Dm 0644 README ${D}${docdir}/analyze-suspend/README
Patrick Williamsb48b7b42016-08-17 15:04:38 -050027}
28
29BBCLASSEXTEND = "native"