Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Programmable Completion for Bash 4" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "Collection of command line command completions for the Bash shell, \ |
| 3 | collection of helper functions to assist in creating new completions, \ |
| 4 | and set of facilities for loading completions automatically on demand, as well \ |
| 5 | as installing them." |
| 6 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 7 | HOMEPAGE = "https://github.com/scop/bash-completion" |
| 8 | BUGTRACKER = "https://github.com/scop/bash-completion/issues" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | |
| 10 | LICENSE = "GPLv2" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 12 | |
| 13 | SECTION = "console/utils" |
| 14 | |
| 15 | SRC_URI = "https://github.com/scop/bash-completion/releases/download/${PV}/${BPN}-${PV}.tar.xz" |
| 16 | |
Andrew Geissler | 635e0e4 | 2020-08-21 15:58:33 -0500 | [diff] [blame] | 17 | SRC_URI[md5sum] = "2514c6772d0de6254758b98c53f91861" |
| 18 | SRC_URI[sha256sum] = "73a8894bad94dee83ab468fa09f628daffd567e8bef1a24277f1e9a0daf911ac" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | UPSTREAM_CHECK_REGEX = "bash-completion-(?P<pver>(?!2008).+)\.tar" |
| 20 | UPSTREAM_CHECK_URI = "https://github.com/scop/bash-completion/releases" |
| 21 | |
| 22 | PARALLEL_MAKE = "" |
| 23 | |
| 24 | inherit autotools |
| 25 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | do_install:append() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 27 | # compatdir |
| 28 | install -d ${D}${sysconfdir}/bash_completion.d/ |
| 29 | echo '. ${datadir}/${BPN}/bash_completion' >${D}${sysconfdir}/bash_completion |
| 30 | |
| 31 | } |
| 32 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 33 | RDEPENDS:${PN} = "bash" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 34 | |
| 35 | # Some recipes are providing ${PN}-bash-completion packages |
| 36 | PACKAGES =+ "${PN}-extra" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | FILES:${PN}-extra = "${datadir}/${BPN}/completions/ \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 38 | ${datadir}/${BPN}/helpers/" |
| 39 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 40 | BBCLASSEXTEND = "nativesdk" |