Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Simple Go-based setuid+setgid+setgroups+exec" |
| 2 | HOMEPAGE = "https://github.com/tianon/gosu" |
| 3 | DESCRIPTION = "This is a simple tool grown out of the simple fact that su and sudo have very strange and often annoying TTY and signal-forwarding behavior." |
| 4 | LICENSE = "Apache-2.0 " |
| 5 | LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 6 | |
| 7 | GO_IMPORT = "github.com/tianon/gosu" |
| 8 | SRC_URI = "git://${GO_IMPORT}.git;branch=master;protocol=https \ |
| 9 | git://github.com/opencontainers/runc;name=runc;destsuffix=${S}/src/github.com/opencontainers/runc;branch=main;protocol=https \ |
| 10 | " |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame] | 11 | SRCREV = "0e7347714352cd7f2e5edc9d2cf838d9934e6036" |
| 12 | #v1.1.0 |
| 13 | SRCREV_runc = "067aaf8548d78269dcb2c13b856775e27c410f9c" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 14 | inherit go |
| 15 | |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame] | 16 | CGO_ENABLED = "1" |
| 17 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 18 | do_compile:prepend() { |
| 19 | # New Go versions has Go modules support enabled by default |
| 20 | export GO111MODULE=off |
| 21 | } |
| 22 | |
| 23 | RDEPENDS:${PN}-dev += "bash" |