Lancelot Kao | c2c04b0 | 2021-02-22 22:55:06 -0600 | [diff] [blame] | 1 | SUMMARY = "foxconn OEM IPMI commands" |
| 2 | DESCRIPTION = "foxconn OEM IPMI commands" |
| 3 | |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 6 | |
| 7 | S = "${WORKDIR}/git" |
| 8 | |
| 9 | DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd libgpiod" |
| 10 | |
| 11 | inherit cmake obmc-phosphor-ipmiprovider-symlink |
| 12 | |
| 13 | EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1" |
| 14 | |
| 15 | LIBRARY_NAMES = "libfiioemcmds.so" |
| 16 | |
| 17 | SRC_URI = "git://github.com/openbmc/foxconn-ipmi-oem.git" |
| 18 | SRCREV = "163226efd02b91994aaa474005979560965ac3d6" |
| 19 | |
| 20 | HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}" |
| 21 | NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}" |
| 22 | |
| 23 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 24 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 25 | FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 26 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}" |