Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | DESCRIPTION = "The gSOAP toolkit provides a unique SOAP-to-C/C++ language binding \ |
| 2 | for the development of SOAP Web Services and clients." |
| 3 | SECTION = "devel" |
| 4 | LICENSE = "GPL-2.0-with-OpenSSL-exception" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4f40a941379143186f9602242c3fb729 \ |
| 6 | file://GPLv2_license.txt;md5=a33672dbe491b6517750a0389063508b" |
| 7 | |
| 8 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}2/${BPN}_${PV}.zip \ |
| 9 | " |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 10 | SRC_URI[md5sum] = "0925d25bc455047b01d4fe9814d30173" |
| 11 | SRC_URI[sha256sum] = "4e74838baf5437e95ae17aa3efb48bd0621f483bff4424f6255fcf327ff80765" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
| 13 | inherit autotools |
| 14 | |
| 15 | BBCLASSEXTEND = "native" |
| 16 | |
| 17 | S = "${WORKDIR}/${BPN}-2.8" |
| 18 | |
| 19 | PARALLEL_MAKE = "" |
| 20 | |
| 21 | EXTRA_OEMAKE_class-target = "SOAP=${STAGING_BINDIR_NATIVE}/soapcpp2" |
| 22 | |
| 23 | DEPENDS = "openssl zlib flex bison bison-native" |
| 24 | DEPENDS_append_class-target = " gsoap-native" |
| 25 | |
| 26 | do_install_append() { |
| 27 | install -d ${D}${libdir} |
| 28 | for lib in libgsoapssl libgsoapssl++ libgsoap libgsoapck++ libgsoap++ libgsoapck |
| 29 | do |
| 30 | oe_libinstall -C gsoap $lib ${D}${libdir} |
| 31 | done |
| 32 | } |
| 33 | |
| 34 | do_install_class-native() { |
| 35 | oe_runmake DESTDIR=${D} BINDIR=${D}${bindir} install |
| 36 | } |
| 37 | |
| 38 | FILES_${PN} = "${bindir}/wsdl2h ${bindir}/soapcpp2" |
| 39 | FILES_${PN} += "${datadir}" |
| 40 | FILES_${PN}-staticdev = "${libdir}" |
| 41 | FILES_${PN}-dev = "${includedir}" |
| 42 | RRECOMMENDS_${PN}-dev = "${PN}-staticdev" |