Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "GNOME library for reading .desktop files" |
| 2 | SECTION = "x11/gnome" |
| 3 | LICENSE = "GPLv2 & LGPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 5 | file://COPYING.LIB;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 6 | |
| 7 | BPN = "gnome-desktop" |
| 8 | |
| 9 | GNOMEBASEBUILDCLASS = "meson" |
| 10 | |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 11 | inherit gnome pkgconfig upstream-version-is-even gobject-introspection distro_features_check |
| 12 | |
| 13 | # gobject-introspection is mandatory and cannot be configured |
| 14 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
| 15 | UNKNOWN_CONFIGURE_WHITELIST_append = " introspection" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 16 | |
| 17 | SRC_URI[archive.md5sum] = "e423ed6d648c6c4f9798fa9cd9ea8d99" |
| 18 | SRC_URI[archive.sha256sum] = "a6393dc5fc29fc0652ac84c73b3da205d0b0168128c4cf6d27797a08f3d07b54" |
| 19 | |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 20 | SRC_URI += " \ |
| 21 | file://gnome-desktop-thumbnail-don-t-assume-time_t-is-long.patch \ |
| 22 | file://0001-meson.build-Disable-libseccomp-for-all-archs.patch \ |
| 23 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 24 | |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 25 | DEPENDS += "itstool-native gsettings-desktop-schemas virtual/libx11 gtk+3 startup-notification xkeyboard-config iso-codes udev" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 26 | |
| 27 | inherit distro_features_check gtk-doc |
| 28 | REQUIRED_DISTRO_FEATURES = "x11" |
| 29 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame^] | 30 | GTKDOC_MESON_OPTION = "gtk_doc" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 31 | EXTRA_OEMESON = "-Ddesktop_docs=false" |
| 32 | |
| 33 | PACKAGES =+ "libgnome-desktop3" |
| 34 | FILES_libgnome-desktop3 = "${libdir}/lib*${SOLIBS} ${datadir}/libgnome-desktop*/pnp.ids ${datadir}/gnome/*xml" |
| 35 | |
| 36 | RRECOMMENDS_libgnome-desktop3 += "gsettings-desktop-schemas" |