Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Lightweight UPnP IGD daemon" |
| 2 | DESCRIPTION = "The miniUPnP daemon is an UPnP IGD (internet gateway device) \ |
| 3 | which provide NAT traversal services to any UPnP enabled client on \ |
| 4 | the network." |
| 5 | |
| 6 | SECTION = "networking" |
| 7 | LICENSE = "BSD-3-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=91ac00c6b9f5c106e89291e196fe0234" |
| 9 | |
| 10 | inherit autotools gettext pkgconfig systemd |
| 11 | |
| 12 | DEPENDS += "iptables net-tools util-linux libmnl libnetfilter-conntrack" |
| 13 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame^] | 14 | SRC_URI = "http://miniupnp.tuxfamily.org/files/download.php?file=${BP}.tar.gz;downloadfilename=${BP}.tar.gz \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 15 | file://miniupnpd.service \ |
| 16 | file://0001-Add-OpenEmbedded-cross-compile-case.patch \ |
| 17 | " |
| 18 | SRC_URI[md5sum] = "03b00c27106835e728a3b858ecf83390" |
| 19 | SRC_URI[sha256sum] = "1aaecd25cf152d99557dfe80c7508af9cb06e97ecad4786ce5dafb4c958d196b" |
| 20 | |
| 21 | IPV6 = "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', '--ipv6', '', d)}" |
| 22 | |
| 23 | do_configure_prepend() { |
| 24 | echo "${@d.getVar('DISTRO_VERSION')}" > ${S}/os.openembedded |
| 25 | } |
| 26 | |
| 27 | do_compile() { |
| 28 | cd ${S} |
| 29 | CONFIG_OPTIONS="${IPV6} --leasefile --vendorcfg" oe_runmake -f Makefile.linux |
| 30 | } |
| 31 | |
| 32 | do_install() { |
| 33 | install -d ${D}/${sbindir} |
| 34 | install ${S}/miniupnpd ${D}/${sbindir} |
| 35 | install -d ${D}/${sysconfdir}/${BPN} |
| 36 | install ${S}/netfilter/iptables_init.sh ${D}/${sysconfdir}/${BPN} |
| 37 | install ${S}/netfilter/iptables_removeall.sh ${D}/${sysconfdir}/${BPN} |
| 38 | install ${S}/netfilter/ip6tables_init.sh ${D}/${sysconfdir}/${BPN} |
| 39 | install ${S}/netfilter/ip6tables_removeall.sh ${D}/${sysconfdir}/${BPN} |
| 40 | install -m 0644 -b ${S}/miniupnpd.conf ${D}/${sysconfdir}/${BPN} |
| 41 | install -d ${D}/${sysconfdir}/init.d |
| 42 | install ${S}/linux/miniupnpd.init.d.script ${D}/${sysconfdir}/init.d/miniupnpd |
| 43 | |
| 44 | install -d ${D}${systemd_unitdir}/system |
| 45 | install -m 0644 ${WORKDIR}/miniupnpd.service ${D}${systemd_unitdir}/system/ |
| 46 | } |
| 47 | |
| 48 | SYSTEMD_SERVICE_${PN} = "miniupnpd.service" |