Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame^] | 1 | SUMMARY = "nanomsg socket library" |
| 2 | DESCRIPTION = "nanomsg is a socket library that provides several common \ |
| 3 | communication patterns. It aims to make the networking layer fast, scalable, \ |
| 4 | and easy to use. Implemented in C, it works on a wide range of operating \ |
| 5 | systems with no further dependencies." |
| 6 | HOMEPAGE = "https://nanomsg.org/" |
| 7 | LICENSE = "MIT-X" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=587b3fd7fd291e418ff4d2b8f3904755" |
| 9 | |
| 10 | SECTION = "libs/networking" |
| 11 | |
| 12 | SRC_URI = "git://github.com/nanomsg/nanomsg.git;protocol=https" |
| 13 | SRCREV = "1749fd7b039165a91b8d556b4df18e3e632ad830" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit cmake pkgconfig |
| 18 | |
| 19 | # nanomsg documentation generation requires asciidoctor, |
| 20 | # not asciidoc, and currently there's no asciidoctor-native |
| 21 | # recipe anywhere in openembedded-core or meta-openembedded |
| 22 | EXTRA_OECMAKE = " -DNN_ENABLE_DOC=OFF " |
| 23 | |
| 24 | # we don't want nanomsg-tools to be renamed to libnanomsg-tools |
| 25 | DEBIAN_NOAUTONAME_${PN}-tools = "1" |
| 26 | |
| 27 | PACKAGES =+ "${PN}-tools" |
| 28 | FILES_${PN}-tools = "${bindir}/*" |