Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "SpiderMonkey is Mozilla's JavaScript engine written in C/C++" |
| 2 | HOMEPAGE = "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey" |
| 3 | LICENSE = "MPL-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=815ca599c9df247a0c7f619bab123dad" |
| 5 | |
| 6 | SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/main/m/mozjs52/mozjs52_52.9.1.orig.tar.xz \ |
| 7 | file://0001-js.pc.in-do-not-include-RequiredDefines.h-for-depend.patch \ |
| 8 | file://0010-fix-cross-compilation-on-i586-targets.patch \ |
| 9 | file://0001-do-not-create-python-environment.patch \ |
| 10 | file://0002-fix-cannot-find-link.patch \ |
| 11 | file://0003-workaround-autoconf-2.13-detection-failed.patch \ |
| 12 | file://0004-do-not-use-autoconf-2.13-to-refresh-old.configure.patch \ |
| 13 | file://0005-fix-do_compile-failed-on-mips.patch \ |
| 14 | file://disable-mozglue-in-stand-alone-builds.patch \ |
| 15 | file://add-riscv-support.patch \ |
| 16 | file://0001-mozjs-fix-coredump-caused-by-getenv.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 17 | file://format-overflow.patch \ |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame] | 18 | file://JS_PUBLIC_API.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame^] | 19 | file://0001-To-fix-build-error-on-arm32BE.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | " |
| 21 | SRC_URI_append_libc-musl = " \ |
| 22 | file://0006-support-musl.patch \ |
| 23 | " |
| 24 | SRC_URI_append_mipsarchn32 = " \ |
| 25 | file://0001-fix-compiling-failure-on-mips64-n32-bsp.patch \ |
| 26 | " |
| 27 | |
| 28 | SRC_URI[md5sum] = "c9473c625ee0a9edaaac8b742ff24c5f" |
| 29 | SRC_URI[sha256sum] = "f9324a6724233ab15f10381fe13e635e89d725ef1e78025a0a7d36c58a84a0f9" |
| 30 | |
| 31 | inherit autotools pkgconfig perlnative pythonnative |
| 32 | |
| 33 | inherit distro_features_check |
| 34 | CONFLICT_DISTRO_FEATURES_mipsarchn32 = "ld-is-gold" |
| 35 | |
| 36 | DEPENDS += "nspr zlib" |
| 37 | |
| 38 | # Disable null pointer optimization in gcc >= 6 |
| 39 | # https://bugzilla.redhat.com/show_bug.cgi?id=1328045 |
| 40 | CFLAGS += "-fno-tree-vrp -fno-strict-aliasing -fno-delete-null-pointer-checks" |
| 41 | CXXFLAGS += "-fno-tree-vrp -fno-strict-aliasing -fno-delete-null-pointer-checks" |
| 42 | |
| 43 | # nspr's package-config is ignored so set libs manually |
| 44 | EXTRA_OECONF = " \ |
| 45 | --target=${TARGET_SYS} \ |
| 46 | --host=${BUILD_SYS} \ |
| 47 | --prefix=${prefix} \ |
| 48 | --libdir=${libdir} \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 49 | --disable-tests --disable-strip --disable-optimize \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 50 | --with-nspr-libs='-lplds4 -lplc4 -lnspr4' \ |
| 51 | ${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', "--enable-gold", '--disable-gold', d)} \ |
| 52 | " |
| 53 | |
| 54 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame] | 55 | PACKAGECONFIG[x11] = "--x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--x-includes=no --x-libraries=no,virtual/libx11" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 56 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 57 | EXTRA_OEMAKE_task-compile += "BUILD_OPT=1 OS_LDFLAGS='-Wl,-latomic ${LDFLAGS}'" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 58 | EXTRA_OEMAKE_task-install += "STATIC_LIBRARY_NAME=js_static" |
| 59 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 60 | export HOST_CC = "${BUILD_CC}" |
| 61 | export HOST_CXX = "${BUILD_CXX}" |
| 62 | export HOST_CFLAGS = "${BUILD_CFLAGS}" |
| 63 | export HOST_CPPFLAGS = "${BUILD_CPPFLAGS}" |
| 64 | export HOST_CXXFLAGS = "${BUILD_CXXFLAGS}" |
| 65 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 66 | do_configure() { |
| 67 | export SHELL="/bin/sh" |
| 68 | export TMP="${B}" |
| 69 | ${S}/js/src/configure ${EXTRA_OECONF} |
| 70 | } |
| 71 | |
| 72 | do_compile_prepend() { |
| 73 | export SHELL="/bin/sh" |
| 74 | export S |
| 75 | export PYTHONPATH |
| 76 | cd ${S} |
| 77 | for sub_dir in python testing/mozbase; do |
| 78 | for module_dir in `ls $sub_dir -1`;do |
| 79 | [ $module_dir = "virtualenv" ] && continue |
| 80 | if [ -d "${S}/$sub_dir/$module_dir" ];then |
| 81 | PYTHONPATH="$PYTHONPATH:${S}/$sub_dir/$module_dir" |
| 82 | fi |
| 83 | done |
| 84 | done |
| 85 | PYTHONPATH="$PYTHONPATH:${S}/config:${S}/build" |
| 86 | cd - |
| 87 | } |
| 88 | |
| 89 | do_install_prepend() { |
| 90 | export SHELL="/bin/sh" |
| 91 | export S |
| 92 | export PYTHONPATH |
| 93 | cd ${S} |
| 94 | for sub_dir in python testing/mozbase; do |
| 95 | for module_dir in `ls $sub_dir -1`;do |
| 96 | [ $module_dir = "virtualenv" ] && continue |
| 97 | if [ -d "${S}/$sub_dir/$module_dir" ];then |
| 98 | PYTHONPATH="$PYTHONPATH:${S}/$sub_dir/$module_dir" |
| 99 | fi |
| 100 | done |
| 101 | done |
| 102 | PYTHONPATH="$PYTHONPATH:${S}/config:${S}/build" |
| 103 | cd - |
| 104 | } |
| 105 | |
| 106 | PACKAGES =+ "lib${BPN}" |
| 107 | FILES_lib${BPN} += "${libdir}/lib*.so" |
| 108 | FILES_${PN}-dev += "${bindir}/js52-config" |
| 109 | |
| 110 | # Fails to build with thumb-1 (qemuarm) |
| 111 | #| {standard input}: Assembler messages: |
| 112 | #| {standard input}:2172: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r2,r1,LSR#20' |
| 113 | #| {standard input}:2173: Error: unshifted register required -- `bic r2,r2,#(1<<11)' |
| 114 | #| {standard input}:2174: Error: unshifted register required -- `orr r1,r1,#(1<<20)' |
| 115 | #| {standard input}:2176: Error: instruction not supported in Thumb16 mode -- `subs r2,r2,#0x300' |
| 116 | #| {standard input}:2178: Error: instruction not supported in Thumb16 mode -- `subs r5,r2,#52' |
| 117 | ARM_INSTRUCTION_SET_armv5 = "arm" |
| 118 | ARM_INSTRUCTION_SET_armv4 = "arm" |
| 119 | |
| 120 | DISABLE_STATIC = "" |