Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame^] | 1 | SUMMARY = "F Virtual Window Manager " |
| 2 | HOMEPAGE = "http://www.fvwm.org/" |
| 3 | SECTION = "x11/wm" |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=f8204787357db6ea518dcc9b6cf08388" |
| 6 | |
| 7 | DEPENDS = " \ |
| 8 | bison-native \ |
| 9 | flex-native \ |
| 10 | freetype-native \ |
| 11 | gettext-native \ |
| 12 | libxslt-native \ |
| 13 | fontconfig \ |
| 14 | libice \ |
| 15 | libpng \ |
| 16 | librsvg \ |
| 17 | libsm \ |
| 18 | libxau \ |
| 19 | libxcb \ |
| 20 | libxcursor \ |
| 21 | libxdmcp \ |
| 22 | libxext \ |
| 23 | libxfixes \ |
| 24 | libxft \ |
| 25 | libxinerama \ |
| 26 | libxml2 \ |
| 27 | libxrender \ |
| 28 | libxt \ |
| 29 | virtual/libx11 \ |
| 30 | xrandr \ |
| 31 | zlib \ |
| 32 | " |
| 33 | |
| 34 | PV = "2.6.8" |
| 35 | |
| 36 | SRC_URI = " \ |
| 37 | git://github.com/fvwmorg/fvwm.git;protocol=https \ |
| 38 | file://0001-Fix-compilation-for-disabled-gnome.patch \ |
| 39 | " |
| 40 | |
| 41 | SRCREV = "dc6a396bfe5cd6c53eb1df103c3af505d0899f90" |
| 42 | |
| 43 | S = "${WORKDIR}/git" |
| 44 | |
| 45 | inherit autotools gettext update-alternatives pkgconfig pythonnative perlnative distro_features_check |
| 46 | # depends on virtual/libx11 |
| 47 | REQUIRED_DISTRO_FEATURES = "x11" |
| 48 | |
| 49 | ALTERNATIVE_${PN} = "x-window-manager" |
| 50 | ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/fvwm" |
| 51 | ALTERNATIVE_PRIORITY[x-window-manager] = "20" |
| 52 | |
| 53 | EXTRA_OECONF = " \ |
| 54 | --disable-bidi \ |
| 55 | --disable-fontconfigtest \ |
| 56 | --disable-htmldoc \ |
| 57 | --disable-imlibtest \ |
| 58 | --disable-mandoc \ |
| 59 | --disable-nls \ |
| 60 | --disable-perllib \ |
| 61 | --disable-rsvg \ |
| 62 | --disable-shape \ |
| 63 | --disable-sm \ |
| 64 | --disable-xfttest \ |
| 65 | --with-imlib-exec-prefix=/nonexistent \ |
| 66 | --with-imlib-prefix=/nonexistent \ |
| 67 | --without-ncurses-library \ |
| 68 | --without-readline-library \ |
| 69 | --without-rplay-library \ |
| 70 | --without-stroke-library \ |
| 71 | --without-termcap-library \ |
| 72 | --without-xpm-library \ |
| 73 | ac_cv_func_mkstemp=no \ |
| 74 | has_safety_mkstemp=yes \ |
| 75 | " |
| 76 | |
| 77 | # show the exact commands in the log file |
| 78 | EXTRA_OEMAKE = " \ |
| 79 | V=1 \ |
| 80 | " |
| 81 | |
| 82 | do_install_append() { |
| 83 | install -d -m 0755 ${D}/${sysconfdir}/xdg/fvwm |
| 84 | # You can install the config file here |
| 85 | |
| 86 | install -d -m 0755 ${D}/${datadir}/fvwm |
| 87 | touch ${D}/${datadir}/fvwm/ConfigFvwmDefaults |
| 88 | } |
| 89 | |
| 90 | # the only needed packages (note: locale packages are automatically generated |
| 91 | # as well) |
| 92 | PACKAGES = " \ |
| 93 | ${PN} \ |
| 94 | ${PN}-dbg \ |
| 95 | " |
| 96 | |
| 97 | # minimal set of binaries |
| 98 | FILES_${PN} = " \ |
| 99 | ${bindir}/fvwm \ |
| 100 | ${bindir}/fvwm-root \ |
| 101 | ${datadir}/fvwm/ConfigFvwmDefaults \ |
| 102 | " |
| 103 | |
| 104 | RDEPENDS_${PN} = " \ |
| 105 | xuser-account \ |
| 106 | " |
| 107 | |
| 108 | # by default a lot of stuff is installed and it's not easy to control what to |
| 109 | # install, so install everything, but skip the check |
| 110 | INSANE_SKIP_${PN} = " \ |
| 111 | installed-vs-shipped \ |
| 112 | " |