Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | LICENSE = "MIT" |
| 2 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 3 | SUMMARY = "Basic grub.cfg for use in EFI systems" |
| 4 | |
| 5 | RPROVIDES_${PN} += "virtual/grub-bootconf" |
| 6 | |
| 7 | inherit grub-efi-cfg |
| 8 | |
| 9 | S = "${WORKDIR}" |
| 10 | |
| 11 | GRUB_CFG = "${S}/grub-bootconf" |
| 12 | LABELS = "boot" |
| 13 | |
| 14 | ROOT ?= "root=/dev/sda2" |
| 15 | |
| 16 | python do_configure() { |
| 17 | bb.build.exec_func('build_efi_cfg', d) |
| 18 | } |
| 19 | |
| 20 | do_configure[vardeps] += "APPEND ROOT" |
| 21 | |
| 22 | do_install() { |
| 23 | install -d ${D}/boot |
| 24 | install -d ${D}/boot/EFI |
| 25 | install -d ${D}/boot/EFI/BOOT |
| 26 | install grub-bootconf ${D}/boot/EFI/BOOT/grub.cfg |
| 27 | } |
| 28 | |
| 29 | FILES_${PN} = "/boot/EFI/BOOT/grub.cfg" |